PDA

View Full Version : Unable to complete quest (fall through world glitch)



chrissyraff
10-07-2018, 02:54 PM
So whilst playing the Penelope shroud mission. I was spotted and started fighting the enemy leader. At this point he falls off a small ledge and then continues to fall through the world. The game will no longer allow me to find the guy stating that he is over 4000m away straight down from my location. I tried to wander around and do another quest to see if this would reset the guy but it hasnít. I tried resorting to a past save and itís still 4000m away straight down. Is there any way to reset the quest or am I going to have to replay 3 hours of the game? Surely there must be a fix? It would be unacceptable to have to go straight back to the beginning? Even origins had a restart from checkpoint option!

ubi--unicorn
10-07-2018, 10:31 PM
Hi chrissyraff. I'm sorry that you're experiencing this! Can you try clearing your Xbox's cache? To do this, unplug the Xbox for two minutes. If that doesn't help, would it be possible to get a video or a screenshot of this issue? Thanks!

nathan.key
10-17-2018, 02:11 AM
I have a similar issue with one of the cultists. He’s now 4000 meters below the map and will not re-appear. I’m on PC. Any suggestions?

mahburg
10-17-2018, 08:49 AM
Out of the map Glitch occurs at the River/waterfall just outside Megaris, makes the underwater animation trigger and there was no way out except to use the fast travel routine from the map.
Cheers

RvffneckShikari
10-22-2018, 11:07 PM
I've experienced a problem with Assasins Creed Odyssey on XboxOne. It's during the Penelopes Shroud mission, the leader holding the quest item was kicked from a ledge and now it's 3m inside a wall and I can't obtain it. None of the autosaves will take me back to the beginning of the mission and I've tried to reset the console a few times but still no luck. I'm 4 hours into the game and really don't want to have to restart, stuff like this shouldn't be happening these days 😂

RvffneckShikari
10-22-2018, 11:11 PM
Ubisoft support on Facebook replied with:-

"I'm sorry to hear that.

I'd certainly advise adding your report to that thread.

Unfortunately there's not really any way to reset quests or NPCs at the moment. So while this may be addressed in a patch, unfortunately the only direct option at this moment may be to start over."

Hopefully this is sorted in an update as the thought of doing all that again is soul destroying 😂😂