View Full Version : "We Remember" Quest by Socrates !BUG!

10-07-2018, 08:37 AM
When returning to Athens to meet Socrates starting the quest "We Remember" We meet Socrates and are here asked to follow him in honoring the fallen. Though when the cutscene ends Socrates is instantly forcedpushed by something killing him, the quest is completed anyways, and no new quest appears "Might not be any". I want to know what happens when following Socrates, and complete this quest... by..... completing it, without Star Wars interfering?

I tried to load a save that made it possible for me to start the quest again, and the bug still accours.
I also tried restarting my game. Nothing has worked. Its annoying asf.

Socrates is apparently destined to be killed by a f**cking forcepush. Any help?

10-07-2018, 09:44 AM
EDIT: The quest says that i need to meet Sokrates at the Athens cemetary outside the city. But Sokrates is laying dead inside Perikles house?
1: The quest and Sokrates that should be at the Cemetary https://imgur.com/a/9frMxa6
2: Location of Cemetary: https://imgur.com/a/mIkFOlu
3: Sokrates dead inside Perikles household (BEFORE activating the quest) https://imgur.com/a/fGkW7PI
4: Socrates dead at the cemetary as soon as Cutscene ends: https://imgur.com/a/ltaUHsH
5: Video that Star Wars exist in ACOD: https://youtu.be/TgSs1dr6eGA

12-14-2018, 08:24 PM

Same problem. He tripped in a cutscene early on and fell in my game. 15 hours later in the game, the 'on a high horse' quest won't start as Socrates is a dead NPC that will appear on location - but I cannot interact with him. Is there a command to reload the character and get him back alive?


12-15-2018, 02:07 AM
This is an odd bug for sure. Can you submit your save file onto a ticket for investigation (https://support.ubi.com/en-US/Faqs/000039882)? Please update this thread with your ticket number once you've made a ticket.

12-15-2018, 12:47 PM
Thanks for the quick reply!

My latest savegame has been uploaded. Reference number 07555278. Looking forward to your response!

01-13-2019, 10:38 AM

01-19-2019, 11:24 PM
Hi Pennyf! Are you still having this bug? Do you happen to have any save files to reload back to?

01-22-2019, 04:22 PM
I just checked up on Socrates. Still dead at the stables so still can't start the 'On A High Horse' quest. See attached save file above.

It's 20 hours in-game time ago so I'm not going to reload back without throwing the game out of the window. I'm not the only one with this bug.


01-23-2019, 11:33 PM
Thanks for the report! Can you submit your save file (https://support.ubi.com/en-US/Faqs/000039882) on a ticket for further assistance? That would significantly help the investigation of this peculiar bug.

01-25-2019, 08:21 PM
Already did:

My latest savegame has been uploaded. Reference number 07555278. Looking forward to your response!

01-26-2019, 01:53 AM
Are you able to provide a save file from the latest update?

01-29-2019, 07:24 PM
Hi UbiSailorScout,

OP is not the only one with this bug. I have exactly the same issue. Making this questline and the depending ones unfinishable. I've created a support case with reference number 07864217. My game is up to date (1.1.3). I hope that you can help us to fix this cursed questline

Kind regards

12-02-2019, 08:44 PM
The quest is bugged. Nothing happens when inside the room. I Have reload a save before enter the room several times.

12-05-2019, 02:37 AM
Hi there, Muskelpinnen!

Are you able to provide me with a video clip of this issue for your game?

06-14-2020, 12:36 PM
Okay, another attempt, a year later it turns out that this bug is still not fixed. I uploaded all technical information and the save file under reference number 11921347.

For the requested video: Socrates is at the location where he is supposed to start the 'on a high horse' quest. The mission horse is already there but because Socrates somehow died somewhere in the game, I cannot start the quest...This is the reason I cannot progress the game.


A command code to make the guy respawn/alive again, or to skip the 'on a high horse' quest is also fine, I just want to progress the story