View Full Version : Game Unplayable - CTD's immdiately.

10-07-2018, 12:24 AM

So, I just got this game for free from AMD Rewards after buying an RX 580 video card...

I was all excited to finally play when I got home from work and the email was waiting, telling me that I could finally download and play the game.

Downloaded, and then tried to launch the game. It gets past the AMD/RYZEN splash screen, and then CTD's. ... then Uplay throws up a pop up suggesting that I go and BUY THE GAME... WTF??

Ok, so I thought that was a fluke, so I closed that little pop up and relaunched the game. This time I make it to the games main screen where it says "press any key" only the text on that is flashing rapidly... like super fast flashing like its trying to alternate between saying "press any key" and something else... but, pressing any key does nothing... other then cause another CTD. No pop up this time fortunately, but I tried to launch the game.. again...

This time it did the same thing, weird flashing "press any key" text, and again an immediate CTD when pressing a key
Now I'm frustrated, so I tried a fourth time.

Same thing.

"Press any key" = CTD....

I tried one last time, and this time after pressing a key, I get into the games main menu screen with a little circle in the center... the circle is flashing rapidly like the text was before, and my Mouse is stuck/frozen to the center of the circle and unusable, and my keyboard.... does nothing...

As again, upon pressing any key to try to navigate the menu... again.


Wow... way to go Ubisoft...

Great Game.

10-07-2018, 12:43 AM
i5-4690K @ 4.7ghz
24 GB DDR3-1600
Samsung 950 Pro 512GB m.2 SSD <---Windows here
Samsung 850 Evo 500GB m.2 SSD
Samsung 860 Evo 512GB Sata SSD <--Game installed here
WD 1 TB Black 6.0Gb/s HDD
Creative Sound Blaster X-Fi Titanium Fatal1ty Professional Series
MSI Armor Mk II RX 580 8GB -- Driver ver 18.9.3-Sept28
Windows 7 Ultimate 64
Acer 27" - 2560 x 1440

10-07-2018, 12:49 AM
Support Ticket # 07122419

10-12-2018, 03:56 PM
So far, support has been pretty useless on this.

They asked for my DXDiag and MSInfo...

Then they told me they couldn't read the files I sent, and asked me to send them again...

Then they asked me to try booting the computer in Safe Mode and try running the game in Safe Mode...

HELLO!!! SAFE MODE?? NO VIDEO DRIVERS LOADED!! The Game failed to launch because it detected, oh gee.. No Video Drivers!

When I told them that, they then told me... oh gee... they can't read the SECOND copy that I uploaded, of my MSInfo file.... and have asked me to upload, yet a third copy...

I'm waiting for a response to that now...

10-12-2018, 04:12 PM
try doing this:

go to C:\Users\(your windows user)\Documents\Assassin's Creed Odyssey

open the ACOdyssey.ini, go to the bottom, edit the input option like this:


launch the game, and go to controls options, switch manually between the K+M setup or controller setup.
try launching the game.

10-12-2018, 04:40 PM
Those lines aren't in my ACOdyssey.ini file...

So I'll add them in, and see what happens.

10-12-2018, 06:22 PM
That seemed to have resolved the issue.

Interesting, as I don't have any controllers connected to my PC, only the KB and Mouse.

10-12-2018, 09:56 PM
....and Ubisoft Support finally responded...

Asking that I, again... send them my MSinfo file, for the FOURTH time...

Their excuse, that they can not use 7 Zip... and that I require a more "normal" zip function to make the file usable by them.

Whatever, it seems editing my ACOdyssey.ini file, as instructed above, seems to have resolved the problem.

10-12-2018, 10:38 PM
Glad you're finally able to play and your issue is resolved.

Regarding the Ubisoft support - Idk. They seem to do their absolute best in responding to many claims, allegations, issues and the ocassional rant here in the official boards at least. And this issue has been fairly often brought up in these forums as well - a simple search would have absolutely helped you.

Anyway, game on!

10-16-2018, 05:42 PM
Had the same issue, that fixed it for me, the auto detect maybe FUBARRED

Many thanks for the tip.