View Full Version : Stuck At Splash Screen too.

10-06-2018, 02:12 PM
I am also stuck at the splash screen. I tried to move the game from one hard drive (C:) to another (D:) and back (C:) after the first move didnt help. OS is on C: .

My CPU and GPU are supported.

After a while, a second Window opens in the background, i think it should be the game starting, but the window stays transparent all the time and the game is not starting at all.

I reverted my GPU driver too, if that was an issue. I dont know any fixes for myself now.

So if the solution of Ubisoft is to change the hard drive to the main hard drive, i have to say NO, this doesnt help me and a bunch of other people in this forum.

I would appriciate other and new useful information.

Thank you

10-06-2018, 04:21 PM
Hi Shurrik_,

What GPU and CPU are you using?

Does the game ever crash or will it stay on the Splash screen indefinitely?

10-06-2018, 04:45 PM
GPU: 1070 TI
CPU: i5-4690k

The game does never crash. I let it run for about 20 mins already.

10-06-2018, 04:51 PM
Thanks for confirming that.

Have you tried a Clean Boot via the steps here (https://support.microsoft.com/en-gb/help/929135/how-to-perform-a-clean-boot-in-windows)?

Thank will see if there is another third party program conflicting with the game.

10-06-2018, 05:01 PM
Thanks, i will try the clean boot in the next 5 hours, and i will give you feedback!

10-06-2018, 11:09 PM
I can confirm that the clean boot didnt help at all :(

10-07-2018, 01:14 AM
read this post and see if it helps work towards a answer. https://steamcommunity.com/app/582160/discussions/0/1483235412214825118/

10-07-2018, 08:18 AM
That seems like quite a specific issue, dapervysage

Although certainly if this is the case for the OP it's worth checking out.

10-07-2018, 08:22 AM
This was a very interesting topic and i put some time and thoughts into it. My main drive is mirrored via a Acronis software from an old and smaller SSD to a new and bigger one. The mirroring worked perfect and the new SSD worked as a new bootable Windows 10 main disk. The old SSD is flashed and still implemented for extra storage (D: ).

So i dont have Storage Spaces, as in the Feature of Windows 10. And i dont think that my C: behaves like a Storage space because everything I researched (Acronis Software, Storage Managment,...) suggests otherwise and it works in completely normal behaviour.

So my game was and is completely on C . I will try to move it to an big HDD now and try to start it but i think Storage spaces is not my problem. AND i think that the "other" people who have this splash screen problem (there are quite many) dont use this uncommon Windows Storage spaces.

Thanks for digging out this interesting solution idea! Looking forward to others.

10-07-2018, 02:13 PM
Sadly it's not working on the HDD either (push)

10-07-2018, 05:22 PM
i could never launch ac origins so i moved sound and dlc to my c drive and dropped a junction link in game directory and the game works now. this is why i shared the link above.

10-07-2018, 05:25 PM
link shell extension is what i used to form a link http://schinagl.priv.at/nt/hardlinkshellext/linkshellextension.html

10-07-2018, 06:12 PM
Thank you again. But my whole game is located at the C: drive (means also the sound files). If i didnt misread you that "work around" your fix, because the sound files are already located right.

10-07-2018, 06:19 PM
Alienware i7 5930. Nvidia 970 x 3. Sli is turned off. Have done all recommendations on steam and here. Nothing. Other up lay games work. AC syndicate . Division.:confused:

10-08-2018, 09:45 AM
What bothers me most is that it doesnt look like that there will be a solution in near future. I really like and want to play this game, but it doesnt look like that I and many other people wont get a solution soon. I dont want to refund this game (and i think i actualy can't). So please set some programmers up for this problem or give pls give me / us a proper feedback in how you are working to solve this issue and please dont try to make us silent.

10-08-2018, 09:49 AM
Hey! I found a working solution from someone else in this community forum posted like 15 mins ago:

Hey Guys!

I had the same problem and was stucked at the splash screen. I tried everything, reinstalled like 5 times, installed on C drive etc.
Now I just went into my Device Manager and disabled the integrated GPU.
I was kinda shocked when i saw that the game was starting

Maybe you guys can solve the problem in the same way.

Thank you @Falterstein!

Ubisoft team: This is the direction you should try to look and solve this. I want to use my integrated GPU for second monitor too in the future

10-08-2018, 01:53 PM
5930k and 1080. Stuck on splash screen also.

10-08-2018, 02:27 PM
I played some this morning nothing wrong.I come back from shopping and now it also hang in splash screen ?????

12-16-2018, 06:58 AM
Hello friends,

I have found a solution for this issue. I installed the game into a VHD unit (P:) created from Administrative Tools > Computer Management and now all works perfectly.

02-01-2019, 05:33 PM
Same problem.

But the fact that this is even an issue, and that the dev's apparently see no reason to address it, is honestly pathetic.