PDA

View Full Version : Game saves just after two minutes of play and stuck on saving for 60sec to 2min



Gaurav9766
10-06-2018, 01:55 PM
Don't know where it goes wrong but game is just saving, saving saving. only i get is saving icon with stuck around 60sec to 2 min. and worst thing is almost occurs in every section like benchmark, menu screen and while in mission. Every time i have to save game from Menu and then if luck it worked otherwise restart game 2-3 times. Its just annoying. I also tried reinstalling the whole game but still.

UbiGabrinth
10-11-2018, 08:49 PM
What game are we discussing and what platform are you playing on? If this is on PC I'd recommend making sure that your game is running as administrator especially if you have the game installed on a different drive than your operating system. If you are on Xbox please try clearing your cache by unplugging your Xbox from the wall for two minutes. Also make sure that you have HD space. If you are on PS4 please try these steps (https://support.ubi.com/en-US/faqs/000025501/General-PS4-Troubleshooting/).

Gaurav9766
10-12-2018, 05:20 PM
Hello, I am talking about "Assassin's Creed Odyssey" and i am playing it on PC platform. I tried to run game by giving administrator rights but now its not even launching. just stuck on Uplay loading screen.