View Full Version : Xbox One Question Assassins Creed Unity Initiates

10-06-2018, 08:13 AM
So, I was on Assassins Creed Unity. I went into my character customization, then gear load out. I scrolled down towards the bottom to the outfits section and looked to see how to unlock that outfit. It proceeded to tell me to log onto Assassins creed Initiates, so, I scrolled down at the pause menu and clicked on Initiates and it said there was an error. I grabbed my laptop and I googled Assassins creed Initiates. I clicked onto the website and it asked for a code. So I checked my game case and didn't find a code anywhere. I already got that outfit on my ps4 so I clicked the link that said code I might have already put in. It asked for my Uplay account so I put in and it said either my username was wrong or my password. So I tried it again and nothing happened. I also tried using other passwords that I could think of but nothing happened. I really want to 100 percent Assassins creed Unity but this minor issue is holding me back. If anyone could help me log into assassins creed initiates or at least help me reset my password because it has an error code too. Please help!

10-07-2018, 06:30 PM
I would talk to support about this, AC Initiates was abandoned some time ago, regrettably.