View Full Version : Can't Launch the Game

10-06-2018, 06:39 AM
Bought the Ultimate Edition for 3 days. I even tried to reinstall the game for twice, and didn't work as well. The problem was like, after clicking the icon and getting through Uplay, the launching box (AC Odyssey logo) appears and stays there with no response. I have tried so many times, sometimes there will be a small window pops up, but still no response (transparent when I switch to it) even after long waiting.

I want to know if anyone has the same problem as I do?

My hardware is 32G ddr3 RAM+6700+EVGA 1080Ti, with the newest version of Nvidia drive and software. Just to confirm, I am able to normally launch and run AC Origin, The Witcher 3, Cities:Skyline and League of Legends, etc. Can anybody help with this? Thank a lot!


10-06-2018, 07:35 AM
Exact same issue...just freezes and then I have to click on it and it freezes, and then closes.

I meet all the requirements (Including the CPU) so I have no idea why its doing it.

Best advice I can give is raise a ticket, it is what I have done, and cross your fingers!

10-06-2018, 09:50 AM
I have the exact same problem...
Tried letting the game run for 20mins without touching anything and yet it's still stuck at the same place.

Made a ticket yesterday with ID: 07110992.
No response yet tho.

10-07-2018, 02:03 AM
Are the games installed on a Microsoft Storage Space (https://support.ubi.com/en-US/faqs/000026541) device? There can be conflicts with Microsoft Storage Spaces, and the FAQ I linked can help resolve such issues.