PDA

View Full Version : Unable to Complete "Fancy Guests" Odyssey Quests



TacoCommander
10-06-2018, 01:08 AM
So I decided to finally do the "Fancy Guests" quest in order to progress in the main story, but for some reason it won't complete. I found the abandoned house and killed everyone there, but the game is still prompting me to try and kill all enemies. The only thing I can think of that might've interfered with the quest was that before I actually wanted to complete this mission I found the house on accident- some of the guards followed me outside of the bounds of the house (they followed me all the way to the statue of Zeus). Killing two of the guards out of bounds might've caused problems. At this point it looks like I'm just going to have to restart from an earlier save.

L1R1K7
10-07-2018, 02:17 PM
not sure if this will help you, but i had the same issue and i have loaded a save 2 hours prior before starting the quest, which of course sucks for me, but it turns out i have missed an enemy somewhere as there are 5 of them and i was only able to find 4 previously as i dragged them back thinking it may do a body count of sorts.

Good Luck

L1R1K7
10-07-2018, 02:24 PM
i have had the same issue, after going back 2 hours in the saves to redo the quest it turned out there is 5 enemies to kill. i originally ran away when i first started the quest and the last soldier followed me quiet a way, once i tracked back the same direction i was able to find the fifth person in my proper save and upon killing him the quest completed.

hope it helps

Jeepika
10-07-2018, 11:59 PM
Same here, killed two inside the house, two down the road but there's a fifth missing, and I can't find him. Searched Markus vineyard, and almost all the island to no avail. Ikarus won't find the thug either.

ubi--unicorn
10-08-2018, 08:17 PM
Hey guys, this has been reported. For a workaround you can go to the nearby locations(e.g. Sami) and look for the bandits fighting the civilians, as the cinematic with Elpenor is triggered once they are all killed.

FlashXAron
10-14-2018, 03:15 PM
ver PC 1.0.3

Great , I would loose 7 hours play as I only have one save !

PLAYING WITH MINIMUM HUD , think that is the reason
but switched now to maximum HUD, but no more enemies on both islands,
as I have killed already everything on both islands ...

will they respawn

FlashXAron
10-14-2018, 09:26 PM
... OKAY solved it !

1.) TURN ON ALL HUD possibilities ...
2.) Move into the middle of the cleared house
3.) Turn around until you see a golden arrow/triangle ... this is where the missing enemies are
4.) Go slowly in that direction ... it was 250m NW for me
5.) when you around 30m from the center the compass will show again back to the house location ... ignore it
6.) Continue to go to the direction it showed, where the enemy should be
7.) after 200m (or whatever your distance was) there should be one missing enemy (In my case he was in the hills, near a bridge)
8.) Don't kill him , lure him back to the quest location, he will follow you ...
9.) KILL HIM inside that 30m circle ...
10.) Cutscene should show, QUEST SOLVED

So the last ideotic enemy is still at the wrong position HOW THAT , but of course with minimal HUD, it isn't solvable !