View Full Version : Unable to download language pack

10-05-2018, 11:54 PM

I like to sometimes play with Japanese audio as that changes the nature of the game and introduces more variation if I feel like I'm getting bored, and I also like listening to different voice actors from time to time.

While changing to Japanese audio via ingame in Origins worked just fine I can't do it in Odyssey. When I installed Odyssey I didn't install any additional languages as I thought I could always download them later as I did with Origins.

However when I enable Japanese in-game it tells me to change the language from properties and uplay will download it for me. Okay - when I go to game settings in uplay and change it to Japanese nothing happens. Uplay doesn't download any additional audio or anything. In Origins this worked just fine.

Is this a known issue? I could try to reinstall the game but I don't want to mess around in case I need to download the whole game again and waiting for tens of gigs to download at this point doesn't interest me much (i.e. I could try moving the game data aside, then uninstalling the game and reinstalling again and when it starts to dowload I could just stop the download and move the backup data back in but I don't know if this actually works...in case if it doesn't I don't want to risk for waiting for a complete new download again). I want to play it safe.

Please, does someone know if this is a known issue or should I make a ticket perhaps? Or maybe someone could verify if moving the game data aside and reinstalling method actually works or not, that would help as well.