PDA

View Full Version : AC Odyssey Not Surpassing 16.33GB in Download



Gingers_
10-05-2018, 08:21 PM
Currently AC Odyssey is not installing correctly for me on Uplay PC. The download gets stuck at 16.33 GB and does not allow me to go any further. I get the message "Download failed. Please check that you have an active connection to the internet and sufficient space on your hard drive, then click retry to start the download again, or try again later.". I have tried to download this a total of 6 times now and it always gets stuck in the same exact spot. Every time I try to download I always launch Uplay as Administrator. Also, I have tried to download it on two different hard drives, both without succession. The first hard drive (C:) has 893 GB of free space and the second hard drive (D:) has 548 GB of free space. Both hard drives are correctly formatted as well. Also, in the case of internet connection I am running via Ethernet into a college campus internet. This internet has a very stable download speed of around 45 mb/s.

My PC Specs:
Intel I5 5500k processor
Nvidia GTX 1060
MSI Bazooka motherboard
600 Watt Power Supply
Windows 10 Home
8GB (2 X 4GB) DDR4 Ram

Please Help, Thanks.