PDA

View Full Version : Quests not working



Assassino1898
10-04-2018, 09:56 PM
I had to start a new game yesterday and even with a new save the quests donít seem to work. The quest in mind is the one called portion control on Megaris, I gnup to the scout and he complains of whatís happened but I canít speak with him at all.

Assassino1898
10-04-2018, 11:07 PM
I would also like to add that I know the quest was working as I did start it in my original save but had to restart the game due to another issue, however this time when I go up to the guy heís making the complaint as usual but no quest comes up and I am unable to speak to him to start it as before he just stands there, Iíve tried reverting to earlier saves but makes no difference :/ and Iím over 10 hours in

Rafe Harwood
10-05-2018, 02:12 AM
Just wondering, but do you actually need to 'start; the quest from the message board? I don't recall.

Assassino1898
10-05-2018, 08:30 AM
In my first save I simply walked up to the guy and then the quest begins, however in this new save he just stands there and you canít interact or do anything with him as yoh should be able to

CodenameAlbino
10-05-2018, 09:33 AM
I get this exact problem. Portion Control can't be started. The scout is there complaining, but there's no quest marker or way to interact.

This, like yours, is a second playthrough. First one Alexios, this one Kassandra.

Ubi-Bandicoot
10-05-2018, 11:28 AM
Hey guys,

Can any of you make a clip of not being able to talk to the scout so we can check this out? Please let us see your current story mission in the map screen in the clip too :)

Thanks

CalculousTitan6
10-05-2018, 12:06 PM
I cannot kill Zosmie, she is stuck 70m beneath the Sanctuary, anyone else have this problem??

Assassino1898
10-05-2018, 03:21 PM
I have managed to record a video of the issue but I cant seem to upload it to this forum. I have also tried loading an earlier save and even reinstalling the game but the issue still seems to occur and even if I go to the cave where the quest takes you that is also empty.

ElCubanPapi23
10-05-2018, 05:47 PM
I have the exact same problem I didnít like the outcome so I started a new game but I canít start the quest heís doing exactly what these guys here are saying I go to him and all he does is look at a tree while near the ambushed site and after he complains he does nothing else I canít start the quest plz fix this issue. And the story mission right now is the wolf hunt chapter, kill the Athenian leader in Megaris Iíve weakened the nation completely and Iím waiting to do this quest with the scout so I can go do the main quest

Pyzono
10-07-2018, 01:02 AM
Here's a short vid, hope this helps.
https://youtu.be/DZuDh4PFPy0

majin662
10-07-2018, 02:17 AM
I am having exact same issue, same conditions. Played all day today and then decided to start over and do some things differently before i got too far and now stuck at this exact point. XB1x here.

Leggey
10-07-2018, 02:48 AM
Exact same thing. Second playthrough since I encountered a bug on first, that didn't let me talk Barnabas. Now Portion Control won't trigger. Dolios just does his script then stands next to the ambush site. XB1X.

Ubi-Baron
10-07-2018, 01:37 PM
Thank you for the extra reports and thanks for the report.

In Pyzono's video the region was already nearly at the Conquest battle stage. Is that the same for all of you guys? The trigger for completing Stentor's task is taking over the land, so it may be that you caused enough unrest already that you don't need to do the other mission.

Pyzono
10-07-2018, 02:27 PM
Thank you for the extra reports and thanks for the report.

In Pyzono's video the region was already nearly at the Conquest battle stage. Is that the same for all of you guys? The trigger for completing Stentor's task is taking over the land, so it may be that you caused enough unrest already that you don't need to do the other mission.

I can see that being the case, and that makes sense. But why limit the ability to gain experience though? I'm sure most people are "ahead of the curve" on their current level being above the recommended level in the zone, but again, why prevent them from getting more? I was just wondering if missing this quest was going to affect another outcome later on in the game.

rthansen77
10-07-2018, 02:45 PM
I have the exact same problem. I restarted the game after some mistakes and now Delios is just standing there. I haven't done anything in the region. I went straight for him to get the quest. I tried reloading and fast traveling back and forth.

majin662
10-07-2018, 04:01 PM
just wanted to say in my case, no that isn't the set up. Mine is bugged and it's the first quest I tried to do upon landing and speaking to the spartan leader. Since this quest is directly ahead of the camp on the way to the main city area i figured i'd do it first but cannot.

Will this prevent me from progressing the story at all? If it won't i could just continue. If it will I'd like to work something out as I've spent a good chunk of money on this between the ultimate edition and strategy guide and it would really upset me to just not be able to play until this is fixed.

ohnomoroo
10-07-2018, 05:24 PM
I have this exact same problem on the PS4. I have just landed so I know that I havenít influenced the area enough for it to disappear. I simply walked up to where the quest would start and he was there talking to himself. His quest does not appear on the map and there is no symbol above his head.

The only quest related to my talk with Stentor (that is not a main mission) is ďMissing MapĒ which I completed, hoping it would trigger the other quests to appear. Unfortunately it did not.

Crystalsouls
10-07-2018, 06:21 PM
I'm also having the issue where the portion control quest won't appear after starting a new play through. I did at first think it was because I'd progressed too far in weakening the region, but I reloaded into several different points, including right after landing in megaris for the first time, and it still wouldn't appear.

Because I can't get this quest I also don't seem to be able to get the quest to hunt don't the mercenary working for athens in Megaris either. (playing on PC)

rthansen77
10-07-2018, 07:55 PM
Hopefully it will be solved soon (I heard something about them doing updates or such pretty often), as the quest probably counts towards 100% completion, thus making it impossible to progress in the game. Sucks being unable to continue playing already.

majin662
10-07-2018, 08:49 PM
Update: while Iím still affected by this bug I was able to progress the story.

Doesnít help those of you who want to 100% and do every quest this go round but just an FYI if some of you want to continue on anyway before waiting for a fix

Rip_Tha_Ripper
10-08-2018, 06:00 AM
I have this bug too! THis is also a second new game I played as Alexios for a while then started a new game as Kassandra. I have this quests bug and also another game breaking quest bug where i cannot recieve the quests a Venomous Encounter in Athens and withou that quest I cannot progress the story any further. as everyone else with these bug have them on a 2nd play?