View Full Version : Survival BUG. Major Glitch.

08-02-2018, 12:43 PM
Hi, first post and unfortunately not a good one...

I have just finished a round in survival as I am building up some cache's for the current GE. Upon reaching the extraction zone I did the regular and killed the hunter. Whilst waiting for the helicopter to land I noticed I couldn't see it even though the pilot had said he was landing.

In short I wound up with an invisible helicopter and the pilot telling me I had 30 seconds to get in. I will add that when the hunter put down his support station (which was near where the helo' would land) it wouldn't take damage? Normally the G36 melts the box but 2 full clips did nothing. And it stayed visible for about 5-10 seconds after he had vanished and rather than "Bang Out" it just glitched away. Maybe it has something to do with the helo' glitch but personally I don't feel it was the cause.

I then tried to run to where the helicopter "SHOULD" or normally would be sitting and holding "F" but nothing happened. The piolet continued to shout the normal but it just wan't there. The orange line and timer was there but no helicopter.

Only having around 4-5 mins left I tried to run to the next LZ but died about 5 seconds (and I mean literally 5 seconds) before it touched down leaving 6 very well earned survival cache's on the floor.

I'd like a response from Ubisoft on this as I have seen something similar before, and being survival is a 2 hour long endurance mission I don't think its fair in the slightest that players are denied their loot for putting so much work.

In case it matters it was the DZ2 landing zone and the time this happened was exactly 12:09pm GMT. I have taken photos of the end results showing I killed the 6 NPC's, had a 146 gear score, crafted all the needed filters & flare etc as well as having a 2:06 game time. Also had my uplay window in the bottom of the pics for further evidence this isn't just a rant.

Hopefully someone from ubisoft etc has the decency to at least respond.


01-23-2019, 12:00 PM
Unfortunately this was lost due to it being posted in the Community Forum rather than the Technical Forum.

I have moved your thread there for visibility and thank you for your report.