View Full Version : I bought it the crew 2 but I can not play on NVIDIA GeForce NOW me from this problem

07-02-2018, 09:26 AM
I bought it the crew 2 but I can not play on NVIDIA GeForce NOW me from this problem

https://imgur.com/a/UsF1XoV :mad:

07-02-2018, 09:27 AM
That is a problem with Nvidia Gefore Now. Nothing Ubsioft can do about that!

07-02-2018, 09:30 AM
so your version is the steam?! did you try install from steam directly and then do play from uplay or gforce now?

07-02-2018, 09:39 AM
my steam version and beta version 1530312634


07-02-2018, 10:44 AM
The NVIDIA GeForce NOW problem has not been solved yet? :(

07-02-2018, 01:20 PM
Hello AntonConforti,
NVIDIA GeForce NOW is giving you the choice between 2 entries for The Crew 2: Uplay & Steam versions. Could you please confirm that you are using the Steam version in the Geforce Now list? (not sure which version is the header for to be honest)

07-02-2018, 04:56 PM
I don't go on steam I go directly to Uplay when I enter on NVIDIA GeForce NOW and the problem has not been solved yet I give the same problems as before here's the link

https://imgur.com/a/wNVu1nD :(

07-02-2018, 09:03 PM
If you have a Steam version, please select this version of the game in your Nvidia Geforce now game list:

The header is for the Uplay version only.

09-30-2019, 04:03 PM
But i own The Crew 2 on Uplay and it only shows the trial verison when i go in it

10-02-2019, 02:49 PM
Hey ItsTheSQUID10,

Have you deleted your trial version of the game and downloaded the full game?

10-05-2019, 01:55 PM
it wont let me acces the client and when i somehow did manage to acces the client it wouldnt let me uninstall the trials version and install the full version