View Full Version : Battleye causing game to crash at random times

06-30-2018, 11:16 PM
Hi, so since the early access for gold members came out, Battleye has been crashing my game after a random interval of time. It never happened in the alphas or betas, but in the full release, with no changes to software on my PC, my game will hard crash without an error message.

I looked at event-viewer to see what the reason could be and it turns out that the battleye service unloads and the game crashes ("File System Filter 'BEDaisy' (Version 10.0, ‎2018‎-‎03‎-‎08T07:34:37.000000000Z) unloaded successfully.") I haven't modified the game's files in any way, I've ran uplay and TC2 as admin, I've verified the files, I've deleted battleye entirely then verified to re download it, and short of reinstalling the game, which I don't think would make any difference, I seem to be out of luck when it comes to actually enjooying the full game. I've read the troubleshooting battleye stuff already and none of it helps me. How is the full release more unstable than a beta just days prior?!

07-01-2018, 12:30 AM
Please first try starting your computer with background applications disabled (https://support.ubi.com/en-gb/faqs/000025721/Disabling-Background-Application/) to check for software conflicts.

If that doesn't help, please go ahead and send us your system files (https://support.ubi.com/en-US/faqs/000023904/How-To-Submit-Dxdiag-MSinfo/), and leave us the case number.

07-01-2018, 10:59 PM
Hi, turns out that reinstalling the game appears to have fixed my issue. However I will update this thread if it happens in the future

07-02-2018, 11:24 AM
I'm glad to hear that, PsychOXRat

Thanks for the update!

07-03-2018, 09:42 PM
So, it seems to have returned after reinstalling, but it seems to follow a similar pattern when the game crashes and that's when I hit an object, be it a wall or vehicle, the game crashes jut before impact. This doesn't happen all the time though as sometimes it's crashed when I've been mid air or just driving down the road normally

07-03-2018, 09:49 PM
Have you tried verifying files since redownloading? Some of the files may have been corrupted. (Uplay (http://ubi.li/8q7wg), Steam) (http://ubi.li/hxurz).

Also, just to double check, have you tried all of these steps (http://ubi.li/mae8v)? Are you getting an error when you crash, or just a crash to desktop?

07-03-2018, 10:05 PM
As requested, here's the case number: 06589623

07-03-2018, 10:07 PM
And yes, I tried all of those things since reinstalling and no errors were found, it' a straight CTD with no error messages

07-08-2018, 11:36 PM
Are you using an Xbox one controller? I had this same issue and switched to a 360 controller and it hasn't crashed since.

07-09-2018, 12:32 PM
And yes, I tried all of those things since reinstalling and no errors were found, it' a straight CTD with no error messages

We are aware of this issue and has been passed on to the dev team, I have just looked for an update, but don't have any new information right now. If you use an Xbox controller, everything should work fine. I know this isn't ideal, but we will try to resolve this as soon as possible.

07-12-2018, 05:30 PM
Thanks for the response, I don't have an Xbox controller so I can't switch to that, so I guess I'll just wait for the devs to hopefully fix this

07-13-2018, 12:01 PM
This issue looks very similar to this in the way the game crashes: https://forums.ubi.com/showthread.php/1907740-When-using-a-Logitech-G27-racing-wheel-the-game-tends-to-crash