View Full Version : Video card stays Idle

06-29-2018, 02:16 PM
I've been experiencing the same fps issues many have. 3770K, 32gb mem, win 10 pro, gtx 980ti XXX overclocked.

When starting the game on what ever video setting it starts out around 35 fps. Entering the startup event it drops to about 8fps and only comes up when I stay stationary.
Driver, settings everything is up to date and improved for gaming.

When checking performance on cpu, network and memory, the bandwidth and utilization are perfectly normal compared to other games.
Then I started tracking GPU performance. Hence the problem arose -> it was in idle state.
Starting another game show the card coming out of quiet mode and going into full blast action. With The Crew 2, it doesn't do anything of the sorts.

A couple of friends have exactly the same system with this difference that one runs windows 7 ultimate and the other having the same config I have (with overclock and everything).
They are running on ultimate settings capped at 60 fps without problems.

Forcing the graphics card to full capacity didn't help a single bit.

Is there someone that can tell me how to get this game to actually utilize my graphics card?

06-30-2018, 12:52 AM
Hi Desert1981. There are a few things that come to mind immediately. You may with to try disabling the overclocking to see if there is some conflict with the game. If you all are using the same cards, please tell me.

The next thing to check is whether the game is using your dedicated graphics card or the card on your motherboard. Please check the display settings in your Nvidia control panel to see what graphics card is being used. It may be the The Crew 2 specifically is set to use a different card.

06-30-2018, 08:21 AM
Hi UbiGabbin,

we are are using the same card (Asus brand). I've already tried the standard clock and it was to no avail.
We all have the HD4000 disabled.
NVidia Control panel is showing the GTX being used correctly.
I'll check into game specific settings, but I'm not aware of setting specific settings for any game. If I run those, I use GForce Experience for that.

Any other thing that comes to mind I might try?
All and every single setting for compatibility has been tried already.

I've cleared the settings to default with Nvidia Inspector and used that tool along with GPU-Z to verify if the GFX card is used or not, the latter being the case so far.

Game specific settings are bound to the global settings and Control panel only sees the GTX, no HD4000 is found anywhere in nvidia tooling.

06-30-2018, 02:24 PM
Try turning off Vsync.

07-03-2018, 10:28 PM
Have tried but no results what so ever :(

I even went as far as completely removing drivers game half of the OS and reinstalling everything with a reboot in between installs.
Nothing works.
Bios is set to use PCIE as graphics card base. Intel HD4000 has been disabled in windows and bios, with no effect.
All settings with NVidia tooling is set to default (even used Inspector to make sure the settings are reset as they should).
Nothing changes (I only get 35 fps when I set everything to low with 1024*768 resolution) bumping settings back up get's me to 7-8 fps (resolution up one will do that)

It seems the video/graphics card init isn't working or it doesn't pick up the driver for some reason... haven't figured out where to find logging on this because OS related logs show everything is working as it's supposed to.
I'm at a loss here and seriously considering a refund at the moment...
Ubi please get me some info on where I can find debug info or logging that I can delve in to and fix this problem... my buddies are running the same hardware with the same settings without a problem. The other win 7 system has the exact same config I have (bios, clocking, hardware, disks.. everything) and he's hitting the 60 fps lock... how in the world :(

07-03-2018, 10:38 PM

Can you go here in Windows 10 setting (Game category, Game Mode, Graphics settings from top right menu) and check what GPU is Windows using for the application?



07-05-2018, 11:22 PM
I wish I could, but I'm running Windows 7 still. I haven't come around fixing a license for Win10 yet.

I am seeing activity on the memory of the HD4000 eventhough it is disabled in windows and bios (using GPU-Z to monitor that)
Also there is some activity on the memory of my GTX 980 TI, but the GPU and Mem bandwith stays in idle (135MHz on GPU and 202MHz on memory).

I'm thinking the memory is used by Windows (Don't recall the name of the fancy transparent taskbar and windows service) which is using the mem.

So to sum up.
Windows 7 Ultimate
HD4000 turned off in BIOS or Windows either one doesn't make a difference.
PCIE set as primary graphics port in the BIOS
Windows and games are using the GTX, except for TC2 which isn't using it at all (according to the sensor of the graphics card).
I don't have any virtual graphics card running
no VMWare crap or Emulators are active (or installed for that matter)
Performance settings of windows are set to High Performance
PCIE power saving is turned off
GTX is in plugged into the primary PCIE port and using 16x
default power settings in the BIOS (which hasn't caused any issues with other games)
Other Ubi games are running fine
Other Steam games are running fine
Reinstalling didn't help
Validation of local files didn't help.
Clean OS install with only the newest NVidia drivers and Steam didn't help.

Hardware check on HD, CPU, Mem, GFX are all fine.
Removing any overclock didn't help either.

Resetting BIOS to default settings didn't do anything (except give headaches with reinstallation of the OS)
Windows is up to date on all patches.
DX installation and VCredist installation done manually prior to reinstalling the game and no result
DXDiag says all is fine and primary GFX is the TI. I doesn't find the HD4000 when turned off.

I'm at a loss here and have spent freaking ages troubleshooting this with no results what so ever.

Thanks for the tips and pointers everyone!!!

Edit: Eventvwr logs are clean on DX/.NET and game things (I have a mic driver that is bugging out giving entries in the logs)
This is not the cause of the problems -> tried running the game before installing the mic with the same result as before

07-07-2018, 09:50 AM

I've went in and gave msconfig a big overhaul. Clean boot settings (ms services only) disabled all startup items and services related to video drivers and other crap (yes Adobe, your crap).
Low and behold -> 5fps

After that I went in and deleted all the nvidia drivers, software and regkeys (massive cleanup), uninstalled the drivers from the driver cache using Device Manager. Reboot into safe mode with networking -> went to windows update and got me some Mickeysoft drivers for the GTX.
I also made sure the HD4000 was not turned on or installed (BIOS is set correctly and hardware is disabled)

Reboot, fired up the game and.... (msconfig settings still in place)

this is starting to drive me bonkers!!! DXDiag shows no errors what so ever. MSInfo has given me nothing but a clean bill of health.

This is starting to slowly choke me like the Logoff Black Screen issue with windows 7 and 10 (monitor, keyboard and mouse going to sleep and NetLogon service crashing).
this last comment is not something I experience at home ;) work related stuff

07-07-2018, 01:49 PM
I know it is probably a stupid question, but have you rolled out any possibility with issues of the connectivity between your primary display and GPU (input ports, cables etc.)?
It is probably an annoying burden, but an idea that came into my head:

1. Re-enable HD4000.
2. Plug display cable into motherboard.
3. Boot the game up while motherboard is used to display desktop.
4. Check FPS.
5. Turn game off, connect display to GPU.
6. Restart PC.
7. Boot the game up while GPU is used to display desktop.
8. Check if there is any change in FPS.

Its just a random idea at this point. You can also try fully removing GPU from your PC, then plugging it back in to check if that had any change.

07-07-2018, 07:34 PM
I haven't thought of that before.
Praise to the suggestion and on I went after reading it :)

HD4000 enabled -> same issue -> same fps
PCIE disabled -> gtx disabled in windows (windows kept the hardware on disconnected state for some reason) -> same fps
removed the gtx -> same fps but increased mem usage and gpu frequency came up to 1300mhz instead of 800mhz
uninstalled the hd4000 within safe mode -> reboot to bios to disable it in full -> reboot (without display) and shut down (powerbutton) -> plugged the gtx back in and connected the cables again
windows ran fine, games ran fine (had to have a marker to compare to), fps for TC2 -> 35 in the opening sequence -> 5 fps after loading to gameworld

I also went in and reinstalled all c++ redist version on my machine. Did the same for .NET (removed 2.0 and installed 4.7.2 also -> old version gone and update from 4.5)
DX installation from the support folder done again -> weird thing is it keeps installing some files on every run, even with reboots in between.

Within the Nvidia tooling the only options to customize are OPENGL based and not DX
I'm starting to believe DX is initialized during start up of the game but not connecting to the graphics driver for rendering and defaults back to CPU for rendering.
Just a wild guess thrown out there, cuz I'm hitting rocks at this point. (not using the powerboats I so desperately want to smash into them right now)

07-07-2018, 07:58 PM
Sad thing is I don't have Windows 7 on any computer available to me to help you out (both my PCs are running on Windows 10). It also feels so damn old at this point now that there are two newer windowses (im not counting Windows 8.0 as a viable OS). I also have bad memory of how stuff worked in Windows 7.

I remember something from a long time ago, maybe from The Crew 1 or some other game that also did not start, wanted to install something. So we had to find the specific .dll files from who knows where, copypaste them into the game folder and then it worked. Could very well be that some driver or other that game installs on first launch are corrupted in the game files etc.

If I remember correctly, in The Crew 2 folder under Program Files (or wherever the game is installed on your PC) is a "Support" folder with some redistributable stuff. Have you tried running any of them manually?

Another idea that pops into mind, that has worked as a solution for some weird issue was to fully uninstall the Uplay client on PC, then restart PC and download and install a new client. There is UplayUninstaller.exe (or something similar) in your Uplay folder, that can be used to uninstall the client. Could you check if perhaps the Uplay client itself is the cause of the low FPS.

These are all wild guesses at this point. If you want, I can help you troubleshoot it together using some chat tool (I'm "Dryminator" on Steam and Uplay, "Dryminator#5960" on Discord. Two brains are more than one.

07-07-2018, 08:09 PM
thanks for the quick come back on this!

I saw some posts from TC 1 that had some relating issues. The dll copy past thing does remind of FSX and GP4 in the old days :) Thanks! Now I'm feeling old too ^^
Good point on the UPlay client, I'll have a go at that and see what comes of it. I'll also check the previous release forums for solutions.

Oh on the support folder-> I tried them all
The only one that fails though is the C++ redist installer (2015 1st release) I have an update version installed and it complains about that :)
DX installs every time, and copying files every time.
the windows patch is already installed on my machine and it won't let me reinstall (crap msp files <- poorly executed good idea)

I'll check back in later... gonna shoot some virtual boats first :) Troubleshooting weird stuff is exhausting

07-07-2018, 11:24 PM
If you haven't already, please send your system files (https://support.ubi.com/en-US/faqs/000023904/How-To-Submit-Dxdiag-MSinfo/) to our team for me. I'd like to take a look. Please leave the case number for your support ticket in a post.

07-09-2018, 09:38 PM
OP, I have the same issue as you. Have you found a solution or received any worthwhile advice from support?

07-11-2018, 06:02 AM
Hi all,
sorry for the late reply...
@UbiGabbin: no can't do anymore. This is the reason for my late reply -> finally switched to Win10

@DestroyerNoise: My solution was to switch OS from Win7 to Win10

Over the last few days I did an OS upgrade (yes I know, not the smartest of things to do with MS products) and it fixed the issue.
Just to make sure it wasn't a fluke or something I went back to win7 with an Image I made of the disk, verified I had the problem and upgraded again.
Problem gone.... again.

I'm not sure what the cause is, but as I mentioned the OS in the other post, the fact an upgrade fixed the problem does kind of support that theory.
For me it seems like something could potentially go wrong on Win7 that makes the game unable to use or not initialize the graphics card.

So from my end, if you experience this issue and have the option to upgrade to win10, please do (it wouldn't hurt doing so in the first place and I should've done it long time ago)

Edit: Just to make sure -> I did an in place upgrade of the OS NOT a clean install (I'll do that when replacing the core comps of the computer)

07-14-2018, 01:28 AM
Dang, I was hoping that wouldn't be necessary, but I knew AAA games would stop working correctly on Win7 at some point. I'm still working with support to see if we can nail down the issue with Win 7 and will update if one comes up.