PDA

View Full Version : Ubisoft Club not working



CaptainCoho
06-27-2018, 06:49 PM
I downloaded and tried to click the link to open Ubisoft Club app on Xbox One X to see the free content I can get through Uplay points. It will not launch through the game or by clicking on the app itself. It gives me the "Something went wrong" message with code 0x80073cf6. No support articles are found at xbox.com/errorhelp. I have deleted and re-downloaded the Ubisoft Club app and hard reset my Xbox. I am still getting the error. I have a friend with a Xbox One X that was able to access the Ubisoft Club app so it appears that my situation is isolated.

ubi--unicorn
06-27-2018, 09:45 PM
Hey CaptainCoho, can you see if these steps (https://support.ubi.com/en-GB/Faqs/000026628/Basic-Xbox-One-Troubleshooting) help?

CaptainCoho
06-28-2018, 04:03 PM
After trying the recommended steps multiple times, I finally got it working. For future reference, what worked for me was reinstalling the Ubisoft Club app followed by a hard reset of the console. Then the Ubisoft Club app was working and accessible by clicking the app or by linking from in-game.

Ubi-Bandicoot
06-29-2018, 11:19 AM
Glad to hear you got it working and thanks for letting us know how you got around it, sometimes the Xbox One needs a hard reset to clear the cache so if you are having issues with anything, it's sometimes best to restart the console and see if it persists :)