PDA

View Full Version : Error when update dedicated server above 4.05m



nthorup
10-10-2007, 01:43 AM
Hey
After instal. 4.06m on a working server installation 4.05m i have this error when try to start the server
"
IL2 FB dedicated server v4.05m
Sound: Native library (build 1.1, target - P IV) loaded.
Main begin: Unknown SFS error: filesserver.sfs
com.maddox.rts.SFSException: Unknown SFS error: filesserver.sfs
Main end: null
java.lang.NullPointerException
"
(I screendump the message in the second it dissapear)
I tryed to make clean installations and new downloads, but nothing works.
does anybody now what cause the error?

nthorup
10-10-2007, 01:43 AM
Hey
After instal. 4.06m on a working server installation 4.05m i have this error when try to start the server
"
IL2 FB dedicated server v4.05m
Sound: Native library (build 1.1, target - P IV) loaded.
Main begin: Unknown SFS error: filesserver.sfs
com.maddox.rts.SFSException: Unknown SFS error: filesserver.sfs
Main end: null
java.lang.NullPointerException
"
(I screendump the message in the second it dissapear)
I tryed to make clean installations and new downloads, but nothing works.
does anybody now what cause the error?

B16Enk
10-10-2007, 02:31 AM
There is a corrupt file for the Ded server out there in the wild.
Looks like you got hold of it.

Check http://airwarfare.com/simnetwork/index.php?name=ForumsPro&file=viewtopic&t=17 for patch sequence.

Full repository of patches here:

http://mission4today.com/index.php?name=Downloads&file=search
(search for 'server').

nthorup
10-12-2007, 04:22 AM
Hey
Thanks for your advice, i tryed but it did not work! I used another pc for testing but same s... happend.
every thing is ok including 4.05m. But after install 4.06m the server is closing down right after initiate. I even had to record the event to get the error message :-(
(Only bug in the test was the 2.04 from "mission4today" which was corrupted, so i used the old one!)

hamselv2
10-12-2007, 06:44 AM
You can get a complete (= all patches included) dedicated server 4.08 here:

http://mission4today.com/index.php?name=Downloads&file=details&id=2417

dbillo
10-12-2007, 10:04 AM
<BLOCKQUOTE class="ip-ubbcode-quote"><div class="ip-ubbcode-quote-title">quote:</div><div class="ip-ubbcode-quote-content">Originally posted by nthorup:
IL2 FB dedicated server v4.05m
Main begin: Unknown SFS error: filesserver.sfs </div></BLOCKQUOTE>
Obviously, it should be saying v4.06m here, so it seems that you have either a corrupt 4.06m server patch, or possibly you are installing a 4.06m GAME patch instead of the server patch.

nthorup
10-17-2007, 05:27 PM
Ups you say the message tells mi that i am using v.4.05 indstead of 4.06, that gave mee spekulations.------- what to do wrong I try to start the server by the file named "il2server_new.exe" that allways work!! But it seems that i was wrogng. Starting the server by the file named "il2server.exe" YES thats the way to do it.-----;-)
thanks for your help!!
UOTE]Originally posted by dbillo:
<BLOCKQUOTE class="ip-ubbcode-quote"><div class="ip-ubbcode-quote-title">quote:</div><div class="ip-ubbcode-quote-content">Originally posted by nthorup:
IL2 FB dedicated server v4.05m
Main begin: Unknown SFS error: filesserver.sfs </div></BLOCKQUOTE>
Obviously, it should be saying v4.06m here, so it seems that you have either a corrupt 4.06m server patch, or possibly you are installing a 4.06m GAME patch instead of the server patch.[/QUOTE]