PDA

View Full Version : (Unplayable) Low FPS In Map Editor On Multiple PC's



Lord-Slitem
03-27-2018, 09:01 PM
So my friend and I decided to get Far Cry 5 so we could build maps together during the holiday, and to our disappointment the map editor ran at around 10 FPS (!!!) on both mine and his computer. It's impossible to play with this low FPS and on top of that the text on the right hand side of the editor becomes scrambled and unreadable when scrolling! Even the editor menu lags.

We both have Acer Predator, his with the original software and mine with freshly installed Win-10 and fully updated drivers.
Campaign works fine on ultra with no lag so our computers should be perfectly capable of running the editor as well.

How can we fix this?

If you don't know of a way, could you provide us an estimate on how long it would take for Ubi support to come up with a fix?
Reason that we need to know is if it takes more than a couple of days we will probably return our games and get something else that we can play this easter.

Alexx1234
03-27-2018, 09:13 PM
Out of curiosity, what desktop resolution do you have and what GPU on the PCs that have issues ?

Lord-Slitem
03-27-2018, 09:25 PM
NVIDIA GeForce GTX 970M

Alexx1234
03-27-2018, 09:29 PM
Interesting. If you manually create a profile for the ArcadeEditor.EXE in the display driver and set it to run in High performance mode or on the dedicated GPU, does it change anything ?

Alexx1234
03-27-2018, 09:33 PM
Interesting. If you manually create a profile for the ArcadeEditor.EXE in the display driver and set it to run in High performance mode or on the dedicated GPU, does it change anything ?

Tutorial: http://nvidia.custhelp.com/app/answers/detail/a_id/2615/~/how-do-i-customize-optimus-profiles-and-settings%3F

Lord-Slitem
03-27-2018, 09:55 PM
Lo and behold, this actually worked.

You sir, saved the easter!

May the easter bunny give you plentiful of eggs, because if anyone deserves them it's you :cool:

Alexx1234
03-27-2018, 09:58 PM
Glad i could help ! Enjoy ;)

justnigs
03-28-2018, 01:53 AM
Can you explain to me how to do this? I'm getting unplayable frames, 13-15 with high end rig using a 1080ti. No idea what is going on.

Alexx1234
03-28-2018, 02:07 PM
The only way i'm seeing someone get such low FPS on a GPU like that is not having the display drivers installed. Please make sure to have the latest one from Nvidia installed.

justnigs
03-28-2018, 02:40 PM
I clearly have the drivers installed. I installed them before I launched. My other games work just fine....

justnigs
03-28-2018, 02:43 PM
So I uninstalled the latest March 27th driver using Displayer Driver Uninstaller and installed the March 20th drivers. All is well now. 120fps on Ultra.

Peanut_Spread
03-28-2018, 06:09 PM
Took the advice and it worked, by default, it ran on integrated graphics which was only 126 Mb of VRAM in my case. This solution boosted it to at least 2600 Mb for me. Thanks

Ubi-Rufus
03-29-2018, 09:55 AM
Thanks for the suggestion Alexx1234.

Glad to hear this got the editor running more smoothly for you.

Mycoolo
04-07-2018, 09:43 PM
I had the same issue.
Cheers.