View Full Version : PC uplay service not available, cant access items/online functions etc. pls help

03-26-2018, 07:38 PM
bought farcry3 deluxe edition directly from the uplay store(sale) yesterday.. installed it and cant get a connection to the servers as the uplay service is not available.
already made a ticket (06070272) but no reply so far.
i have already read about this problem and tried everything with ports forwarding etc. and never thought that this is still a problem after so many years :(
all other installed games on uplay i have are running without problems.
please help/advise

04-27-2018, 04:52 PM
over one month now and i stil cant use online functions or be able to access my deluxe edition items due to no connection to the server... still.

i dont know what to say, because my last problem i had with a directly bought uplay game even took nearly 2 month before it was solved and i was really hoping that these long waiting times were an execption....

07-28-2018, 07:06 AM
we have reached 4 months now without solving the problem.
far cry 3 deluxe edition is not possible to play for me, as i can not get a connection to the server to be able to claim the deluxe edition items/functions.
i do not have this kind of problems with other ubisoft games (or any online game for that matter). i have tried everthing possible from my end and nothing helped.
then i got another key to register the game (as it had no key because it was bought directly ftom the ubisoft store).
my library was showing now 2 versions of the game (the extra key i got was for the standard edition) but i still was not able to connect to the server.

now, since nothing helped i was asking to please delete the game from my library and to refund it.

well.. they deleted it.. the deluxe edtion i bought initially .... and left me with the standard edition ....yeah... thats it !?

dear ubisoft, please....