View Full Version : Assassinís Creed Unity wonít load until I download content and risk losing progress

01-18-2018, 03:11 AM
Okay so, I realize I might be late to this party, but I tried to load my Unity game several weeks ago and when I selected to load my game, a screen popped up saying ďyou cannot continue your game until the required content is downloaded. Do you want to start a new save? You will lose all your progress.Ē I tried to load my game again just now and got the same pop up. I donít know if Iím just reading this wrong, and by clicking ďyesĒ I wonít actually lose progress, but if Iím not, Iím really not keen on the idea of losing everything, especially since Iíve nearly completed the whole game. And of course, Ubisoft tech support seems NONEXISTENT which is a huge help, thank you, and Iíve trued looking many other places for an answer and getting nowhere. This is one of my absolute favorite games and I really donít want to lose everything on it. Can anyone please help?

01-21-2018, 07:26 PM
I had this problem too when I came back to Unity after replacing the HDD in my PS4 (and hence had to reinstall all my games). It was because when I had last left the game I was in Franciade so of course it wouldn't let me play on that save until I had download Dead Kings. After I downloaded it everything was working fine.

Hope that helps.