View Full Version : Aya: Blade of the Goddess GAME BREAKING BUG

11-21-2017, 04:23 AM
Last week I was playing ACO on my Xbox One S, my latest story line mission was called Aya:BG (I didn't engage on anything to trigger that mission from where Bayek and Aya find the decapitated body). From there I turned my focus on completing and exploring locations around the world. My issue starts after weeks of playing just side missions and reaching level 40, when I traveled to this village I saw a side mission near me and required me to speak to a story teller near people listening to him. I continued and when I was told if I wanted to hear his story I was then taken into the sync loading screen, just as if I was about to change Bayek to another character. When everything loaded I was found in an ocean along Aya, Bayek and a Roman (idk the name) on a ship. I wasn't able to speak to her or interact with anything, just navigated clueless since no one talked or had any suggestions of what to do. After restarting my console for the 2nd time I came back to ACO and I was stuck in a loop of a broken mission. I was able to roam around the sea but was trapped by invisible barriers. I tried killing myself with the damage I was taking from trying to pass the barriers but it lead to a more buggy an destroyable ship (after ending the health bar, it still was movable). The NPCs rowing where dead in flames while I sailed to other barriers in search of a checkpoint or objective. None worked. So I reinstalled my ACO and I was greeted back with the same mission, unable to progress or get back into free roam. The only objective listed was to speak to Aya but I couldn't, I still cant after reinstalling the game. I put so much time into the world to get most done and even reached level 40 before attempting the story line, I am getting really frustrated at the fact I cannot do anything and don't want to start over again since my life style doesn't allow it. I even invested on the gold edition, yet this game breaking glitch is really holding all my time spent into a waste. I frankly don't want to start again even if I know how to speed the game, so please look into preventing this issue for other players who want to be free to explore and not wager their whole time into loop bugs. If its possible add an alternative way to exit missions (like mine in particular) incase something goes wrong. I restarted (menu + Y button) the mission multiple times and it did nothing, see if you can implement an exit back to Egypt's free world. Hopefully that can help me NOT lose my progress. See into my details maybe the bug is triggered by not talking to Aya before the Story teller... even after a fix ,do see into my suggestion. I want to finish this game, not have my money wasted and time. Thank you for your time.