View Full Version : Mounts not working

11-18-2017, 03:42 PM
Just purchased the game yesterday and I am having issues with my mount.

My issue:

-I purchased a new mount before completing the prologue and gaining access to the zone
-Prior to this my mount would come whenever I hit the summon mount button (down on the d pad)
-After purchasing the mount (I bought a horse), my mounts stopped summoning and nothing would happen
-Bayek would still make the whistling sound but my mount would not come
-Interestingly, when I first traveled to the new zone, my mount was a camel again.

Can somebody please help me out? I really do not want to have to reinstall my game as I had purchased it digitally.

I have tried everything. fast traveling to Siwa, fast traveling to different synchronize points, restarting my xbox, restarting my game. Nothing has worked thus far. I even purchased another new mount and that still hasn't worked.

11-18-2017, 04:01 PM

Did you get the double whistle type when you summon your mount?

There are a few parts where the mount cannot travel to, so it would be running around somewhere trying to get to you.

Go to your gear menu, change the mount and try it. Try a different mount.

You would also get a Galloping Horse icon when you summon it from the direction it would come

11-18-2017, 04:13 PM
I feel like an idiot now
I didn't realize I had to hold the button. I was just pressing it twice lol.

11-18-2017, 04:15 PM
LOL. Happens. Glad it is not a bug.

So now, you may have fun with the game & your newly purchased mount.