PDA

View Full Version : Addon Activated Loop. Can't play Anno 2070



Steve_Asgardian
11-10-2017, 09:12 PM
I have a problem and don't know what to do next.

1. When i start Anno 2070 tru my desktop as admin rights it starts up.
2. Then i got the message "Addon activated" (see picture).
https://preview.ibb.co/dxFv3G/screenshot0000.jpg (https://ibb.co/kXVjxb)
3. As you can see i have only the option "REBOOT"
4. When i click that the game starts up again and again the same message. every time i press REBOOT.
I activated my key for the game as well on UPlay.

Now what must or can i do.

Steve_Asgardian
11-12-2017, 12:23 PM
It seems that i have to buy and install Deep Ocean again.
In order to fix that loop.

Mr_B-
12-12-2017, 02:57 PM
Not sure why nobody responded sooner to this. It's pretty much a known issue, and it seams UBI'soft isn't going to, or simply cant, fix it. The autopatcher freaks out, and fails the update. The solution is to replace it with an older one, run it manually, and then launch the game, which will trigger a CD key request for the original game, and after that everything will work as intended.
I suspect you could use the autopatcher of the DVD, if you have those.

More details, and link, here (https://forums-de.ubi.com/showthread.php/130027-Anno2070-keeps-asking-to-REBOOT-(for-dlc-s)-Addon-activated-loop-Forums/page2).

Mr_B-
02-10-2018, 11:14 AM
I cant believe this still isn't fixed yet. The last few days have had a major issue with the loginservers, and for what ever reason during those my game decided the deep ocean addon needed to be activated again. Since that wasn't possible, the game apparently removed it. And when it was possible to log back on to the servers, i got stuck in the activation loop again. Yey

UBIsoft. Fix this already?

toukan2
02-13-2018, 07:16 PM
I have the same issue

Ealdwine
02-14-2018, 03:11 AM
I had the same problem. I used the autopatcher.exe file on my disc of Anno 2070 Deep Ocean, after a couple of small updates it allowed me to log in and play. I hope this is helpful

dmdilks
02-14-2018, 03:07 PM
Ok what the problem is that yes you own the add-on, but it isn't in the game inventory. When you go to install 2070. I try all the things that everybody has said that might work. You know like jumping through hoops.

Well how I fix is I went to Ubisoft and bought the game again. Yes I know why but I sick of all this crap. It cost me $5 to fix it. When you go to install the game it will tell you it has to download about 6.02 gbs. After I bought it is now saying when you go to install the game now you have 6.38 gbs. So what is happening here yes you own it, but Ubisoft/Uplay never added it the your inventory.

Plus this all started after the came out with 2205. Up to that point I have not had any problems. You might try to contact support to see if they can fix it by adding the game to your inventory. Plus make sure you have all your keys for both of them it make things go more smoothly.

BeetrootPancake
03-17-2018, 02:49 PM
here you go
https://support.ubi.com/en-GB/Faqs/000025468/Error-after-activating-Deep-Ocean

ricgecomet
03-25-2018, 02:39 PM
https://support.ubi.com/en-GB/Faqs/000025468/Error-after-activating-Deep-Ocean
It doesnt work for me.. offline patcher give some error saying anno not installed, already update, and corrupted install
I have steam version

Cheatyx
03-27-2018, 12:13 PM
I just dont buy another Uplay Game, until they fix this, its so anoying.


Download Patch manually
http://static2.cdn.ubi.com/patches/anno2070/Anno2070_Offlinepatcher_2_00.zip
But then you need to Enter the CD-Key,(i Saved mine), if you dont have try to repair or something...

SycosidWrestle
04-21-2019, 01:06 AM
here you go
https://support.ubi.com/en-GB/Faqs/000025468/Error-after-activating-Deep-Ocean

Sweet worked fine for me :cool:

Cheers Saul

tabarus
10-06-2019, 04:36 PM
I installed thepatch manually but now it ask for a cd key ?!

tabarus
10-06-2019, 05:06 PM
related:
https://support.ubi.com/de-DE/Faqs/000025265/Locating-your-activation-key-in-Uplay-PC-UPC

Ubi-Woofer
10-09-2019, 11:16 AM
I installed thepatch manually but now it ask for a cd key ?!

Hey tabarus, would you mind clarifying for me if you are continuing to have the main issue that this thread describes with the autopatcher / patch loop?

Additionally, with regard to the request for an activation key, is this following your launch of the game? Can you provide me with a screenshot of this, so that I can best-understand the issue? You're welcome to PM me the details / screenshot if you would prefer, or if it contains personal information.


related:
https://support.ubi.com/de-DE/Faqs/000025265/Locating-your-activation-key-in-Uplay-PC-UPC

Were you unable to find your activation key for the game using the steps in this FAQ?