View Full Version : His Secret Service bug

11-10-2017, 12:28 AM
Was just clearing the camps and the mission came up to carry prisoner out of camp, dident think much of it, mainly just wanted to clear the camp and come back for mission, but wen I did the prisoner is no were to be seen. I tried to reset the mission but the prisoner is not showing neather is a marker.

11-10-2017, 04:14 PM
Have you completed the 'Shadows of Apollo' quest? If not can you try completing that first and then retry 'His Secret Service' quest.

Please confirm if this resolves your issue.

11-12-2017, 01:09 AM
I've got the same issue, and have completed the Shadows of Apollo quest which did not fix the issue.

11-13-2017, 07:57 PM
For me, "Shadows of Apollo" has already been completed but i am stuck on a bug in "His Secret Service". The objective says to "Rescue the prisoner" But there is no prisoner in the Roman fort for me to rescue. The cage is empty. Please reply and help me :(( I'm a completionist so you can understand how this is irking me..

11-14-2017, 06:55 PM
I have the same problem, i've completed Shadows of Apollo and have tried to reset the quest but it does nothing.

11-15-2017, 03:40 AM
If you go to the ruins to the east of the fort, the prisoner there waiting. He will start talking to Bayek and trigger the next check point in the mission.

11-17-2017, 12:18 PM
That worked, i found him at the base of the ruins in front of a tree. Thanks!