View Full Version : Trails of the gods... Not showing up!

11-09-2017, 09:16 PM
To anyone that can Help me. The Trails of the Gods event does not show up for me... I go to the location in the Great Sand Sea area and I see or get nothing I have traveled all over the area in hopes to find it but I'm NOT getting anything. PLEASE @UBISOFT can someone help me, I want to be able to play the event. PLEASE HAVE SPECIFIC descriptions about your events upon release. That would be helpful to everyone who doesnt understand your game FULLY. ALSO, do i need to beat the game in-order for the trails to APPEAR?... PLEASE STATE THAT next time on your website....... PLEASE BE DESCRIPTIVE. This isn't fun, playing guessing games for a TIMED-EVENT... it becomes a part-time job and not a source of entertainment. THANK YOU to whoever that can help.

11-10-2017, 05:43 AM
Hello Assassin! We're sorry to hear you've been having difficulty locating the Anubis Trial. Since you mentioned that you have searched everywhere in the area and are still unable to locate this content, please be sure that you have already completed the prologue in the actual game and have installed the update containing the Trials of the Gods. If all of this is completed correctly, try going out of the Animus and then load back in and see if this will prompt the quest to appear as intended for you. If you have completed all of the steps listed here and are still unable to locate it, please do not hesitate to report this to our technical support team (https://support.ubi.com/Cases/New) and share a list of the steps you tried prior to reaching out for further assistance so that this can be further documented for investigation or reviewed and addressed. Thank you!

11-10-2017, 05:49 AM
In addition to the troubleshooting provided please note that when this update is run, you should have a new quest on the Quest Log named Trial of Anubis and it will give you some details about what to expect and what rewards you can earn. There is also an indication on this listing of how much time you have left to complete the trial before it is no longer available. Tracking the quest places a gold marker on the map for you to follow and a blue marker will appear on the world map to indicate where the boss is located. Hope this helps!

11-10-2017, 07:03 AM
I just bought this game too and I keep clicking on the trial of gods thing on the right side of the screen. Sorry I forget what it's called. But. I keep clicking on it and I get nothing also.

11-10-2017, 09:01 AM
Thank you Paws for your help. Just a note: BUT the reply button to your reply post does NOT work, incase you wanted to let ubisoft's web designers know.
On the subject at hand, I have tried your suggestion and it did NOT work.

Where I'm at right now in the game: (PLAYING ON XBOX ONE)
1. Currently at level 11
2. Currently pursuing my final target in the game " THE SNAKE"
3. Based on the main menu I see I have patch update 1.0.4
4. I can see "First Trail of the Gods now available" tab on the right side of the menu screen. Yes I have tried clicking onto it, It does nothing.
5. I currently have 5 quests: 3 main - "Gennadios the Phylakitai", "End of the Snake" & "Aya". 2 side - "Taste of Her Sting" & "Bayek's Promise" - NOTHING FOLLOWS (meaning there is nothing else, nothing under EVENTS (0) ) < - - Just to be clear.
6. "Trails of Anubis" or "Trails of the Gods" or whatever name is given to this event is NOT shown. NO ICON on the Map. NO Quest info. NOTHING. expect in the menu screen where the tabs are.

1. Completed the Prologue.
2. Walked around with my camel and had Senu fly around the Great SAND SEA area for over 2hr ... just searching (LIKE AN IDIOT).
3. Exited out of the game. reloaded the game. check for new updates to the game. - - (STILL NOTHING)
4. loaded into the Animus, logged back into the game (Bayek quests that is).... again NOTHING.
5. Pressed (Y) to "RELOAD QUEST OBJECTIVES" . . . again NO luck.

I'm not sure what to do . . anymore. I am completely bummed out by the fact that I will miss out on this event and the items, so if anyone can help. I will forward this post to tech support. If you could keep me up-to-date on if the devs are looking into this bug that would be greatly appreciated. Thank you again PAWS.

machine monkey
11-13-2017, 02:05 PM
I didnít get the trials of Anubis icon on my map until I hit level 20 ! Also you have to be very high level to attempt it , level 40 recommended !