View Full Version : STUCK inside Aya’s Blade of the Goddess Mission

11-07-2017, 03:00 PM
So I am somehow on the ship with Aya but my next step says to “Speak to Aya” only problem is that is not possible. I try and navigate the ship forward and just end up hitting an invisible wall. I cannot abort, and when I reload it does not change anything just right back where I started. PLEASE HELP ME!

11-09-2017, 12:54 AM
Same here :(

11-09-2017, 04:21 AM
Basically youre ****ed. Just had support reply to me. Sorry its bugged out and no way to restore an earlier save, please start a new game as we try to resolve the bug. The most arrogant company ever and not even implementing an autosave file/ hard save file system .

11-12-2017, 05:51 PM
Same here Stuck on Aya Blade of the Godess
can't skip or load early save .. damn it


11-13-2017, 02:33 AM
Same! They said they were denying access from Ambush at Sea and they didn't - I didn't know about the bug, I've spent 60 hours, I'm at level 40, and decided to go back and do the mission as i try and finish up the game. Now i'm stuck playing Aya on the boat but with the Blade of the Goddess mission...i'm scared to do anything at all and i 'm scared that even once they fix it, because i've already started the mission, i'll be f***ed

11-13-2017, 06:09 AM
I started the Ambush at Sea mission, but found myself stuck in the Aya: Blade of the Goddess mission on a boat and couldn't do anything. Like others have mentioned I could sail for awhile then I ran into an invisible wall. I went to the start menu and reloaded quest objective it took 3 tries but I finally got loaded back to Ambush at Sea.

11-20-2017, 02:10 AM
If you reload the objectives enough time it will load the mission so it can be completed.

11-20-2017, 11:50 AM
Hey everyone,

Could you provide me with some additional information?
Such as:
- Did you have the Blade of the Goddess quest tracked before entering the Ambush at Sea quest?
- Which mission did you play before it bugged out?
- Did anything out of the ordinary happen during the quest before the issue happened?


12-02-2017, 08:39 PM
Has nothing been done about this?

12-02-2017, 09:51 PM
Hi, got out of this by reloading quest objectives, but have lost all weapons , shields, all items and gold.

12-03-2017, 08:12 PM
Im stuck on this mission as well. But not Ambush at Sea in a Tomb following the mission. There is a cut scene to open Alexander the Great's Tomb as Aya and that will not load for me. It saved during the cut scene now wont load the game or the cut scene.

03-12-2018, 10:20 PM
I started this level and I can’t quit it or abort the mission!!! Anyone know how to fix this

08-07-2018, 10:36 AM
Hey! I know this comment is from last year but I fixed my glitch. I did a hard reset on my Xbox and I let the cinematic play all of the way through. It worked!