PDA

View Full Version : [PS4] Total Gamebreaker - Defend Caesar



AlecDelorean
11-05-2017, 09:03 AM
I put 95 hours in the game so far, on lvl 40 and gear maxed out. I finally decided to follow the storyline, but now i'm totally stuck at Battle of the Nile - Defend Caesar Quest. I already tried to restart the game/mission/console 20+ times, but i'm always stuck with just one spear only when the mission starts and this way it is absolutely impossible to get through the scripted events. I remember having a bow the first time i tried it, where i was limited to 9 arrows (also impossible), the second time i suddenly had a limited amount of spears. Since the 3rd restart i'm stuck with just one spear only. I already read that this happened to some people, UBI please fix this ASAP!

AlecDelorean
11-06-2017, 05:13 PM
Bug still present with patch 1.04! I can't play the game because it's totally broken. No way to choose a bow, i'm just stuck with one single spear.

Ubi-Keo
11-06-2017, 06:13 PM
We are aware of this issue and the team is currently working on a fix. I apologise for the inconvenience this has caused.

GGP_Andy
11-06-2017, 09:20 PM
Thanks for the update, glad to hear a fix is being worked on :)

Kind Regards
GGP_Andy.

TehItalian
11-07-2017, 10:34 PM
Thanks for letting us know that you are working on it but could you tell us when you plan to release the update because at the moment I canít do anything, I have been looking forward to doing the Gods Trails, but I am in a continuous loop with only one spear and no way of quitting the mission, I would very much appreciate it if I was told weather or not I will be able to play both the game and the Gods Trials or not.

gabzd13
11-09-2017, 05:23 PM
New patch today and still nothing :/ still bugged