View Full Version : Playing with fire side quest

11-01-2017, 03:31 AM
I'm trying to do the Playing with Fire quest at Kyrenaika Roman Citadel, unfortunately I desynchronized and when I respawned, the objective to destroy the barrels of the flammable substance had disappeared. In my quest log, all objectives are marked as done, and I cannot access the quest objective anymore. I still have Vitruvius' Formula. I tried doing the reload quest objective, but it doesn't help in this particular case it just shows the formula note I took from Vitruvius. Please help

11-06-2017, 03:03 PM
Unfortunately it seems as though you have encountered a glitch. If you are unable to replay the quest objective then there would be nothing further you can do to resolve this issue, for which I apologise.

I will report this to the Assassin's Creed Origins team.

Do you have a video that you can provide?

01-14-2018, 04:54 AM
Hey, I'm the same.
I'm upto "HELP VITRUVIUS WITH HIS PROBLEM" and I can't find any Mark, I tried looking online etc to help try and retrace my steps.

01-17-2018, 06:59 PM
You have to play the quest the good Roman