View Full Version : PC found a bug for the quest "his secret service"

10-31-2017, 08:33 AM
when playing this quest,and help prisoner, after talk from him, hes ask for you found centurion. But problem, no quest marker and no hint as to what i need to do. Devs please fix.

11-08-2017, 02:34 PM
Having the same problem on Xbox One

11-09-2017, 03:09 AM
Same problem, can't find the centurion in any of the towers and no yellow quest marker.

11-09-2017, 05:23 PM
Same problem on the PS4, when you need to retrieve the spy list there is no marker quest to find the centurion...

11-10-2017, 12:39 AM
I have the same trouble with this mission and the Shadows of Apollo mission. No waypoints come up.

11-10-2017, 12:55 AM
It's a bug with the location, not the quest. Sometimes location leaders can be drawn out of a location and for whatever reason they don't wander back home. Use Senu to check in a wide area around the location, I've always found them to be within ~200m of where they should be (I've encountered this bug 3 or 4 times).

11-10-2017, 05:17 PM
Same problem, the prisoner isn't in his cage and no waypoint.

11-12-2017, 06:43 AM
I discovered that if you Reload Quest Objective, a single quest marker now appears for both these side missions, in my case at the Hydrax Roman Camp. When I retrieved the list, both side missions completed.

11-13-2017, 12:21 PM
I'm having trouble on PS4, even with Father Jack's tip. I've run from Bemulos to Livius to Hydrax and back, nothing. Hell, I even let the soldiers light the brazier first, just to make sure there's no one out in the field. This guy is harder to find than Carmen Sandiego in a ghillie suit.

11-15-2017, 03:44 AM
If you go to the ruins to the east of the fort, the prisoner there waiting. He will start talking to Bayek and trigger the next check point in the mission.

11-15-2017, 12:06 PM
Xboxone, i've the same problem. I won't get de mission indicator. I've restarted the mission nothing happens. Same with useing Senu also nothing happenz

11-15-2017, 12:30 PM
We've reported this bug to the developers and it's being investigated.

In the meantime, I'd advise you try the suggestions posted in this thread.

11-22-2017, 06:08 PM
Tried reloading quest objective, I looked for the prisoner in the ruins to the east, I searched Hydrax Roman Camp, I used Senu in all these locations, nothing.

11-23-2017, 12:31 AM
I was also having trouble with finding the Centurion, but then he appeared after I completed a side quest. I don't remember the name, but I do remember rescuing a prisoner.

11-24-2017, 04:38 PM
The problem solved itself after competing Shadow of Apollo quest which is practically the same quest with a different name, it points to same centurion and you can finish both quests at the same time. Still the quest is bugged, you shouldn't have to rely on another quest to point you in the right direction.

12-02-2017, 05:59 PM
I am experiencing the same problem with both missions (bow of Apollo and his secret service) . i tried everything : searched the prisoner at the ruins, restarted the missions, died and reloading. nothing happened. it is my last 2 missions please any advice would be appreciated
thanks in advance

by the way, regardless what the 1.10 patch is saying this has not being fixed

i still can' t find centurion and i have many times have tried everything.
i can get a game being baggy but this is by far the most buggy game ever.

01-16-2018, 03:42 PM
I still cannot complete this quest, there's no map marker for the person I need to kill or anything, I've been to every location on the map and still, nothing >_>