View Full Version : Stuck in opening to Ambush at Sea / Talk to Aya

10-31-2017, 06:30 AM

I've now progressed to level 30 in game, and decided it was time to backfill and play some side quests. I've loaded up the Ambush at Sea, and instead of an opening cinematic, it loads on the ship directly, with NO enemies and a quest objection of 'Talk to Aya.' I only know what should happen thanks to people posting youtube videos of their play-through.

I've reset the quest objectives (via the menu), and it has the same issue. I've also rebooted the entire xbox one, and the save game file is stuck at in that mission, at that point. Reloading doesn't fix it, and now I fear I've lost my game's progress. With 1d18h18m in, this would suck. Sometimes resetting the quest objectives results in both Aya and Batak being on the boat, which isn't right either!

Is there a way to fix this on xbox one, please advise. I'm really hoping there is a way to fix this.

10-31-2017, 02:19 PM
Unfortunately it sounds as though your save file is corrupted. Do you have any other quests showing in the menu screen? If so are you able to select another quest and leave the area? Have you also tried to fast travel to see if that works?

10-31-2017, 03:29 PM
I have no options to pick another quest or select anything else. With a corrupt save, is all my work lost? (If so, this is a terrible design that won't allow me to abandon the quest, which is greyed out and not an option.

So my game is lost? (That seems extreme that I've lost 42 hours of gameplay!)

10-31-2017, 03:30 PM
Is there a way I can copy my save data in the future to prevent this? (On xbox one.)

10-31-2017, 03:55 PM
I forgot to note that all quests (other than the active one) are greyed out and I cannot select another one. The world map is disabled, so no fast travel.

This stinks, I really hope there is a fix.

10-31-2017, 09:32 PM
Nearly the same here, I also tried to play that Mission, the Storyteller starts, it was loading, then the ship was alone, without enymies, refreshed the Mission and it worked, back at the storyteller, Bayek stands there with the stuff of Aya, EVERYTHING of my progress in the Game is gone, seems its overwritten with the Inventory of Aya.

Tried different things, nothing works.

Thats very dissapointing, hope Ubisoft will find a solution very soon.

11-01-2017, 12:20 PM
I decided to play the ambush at sea quest since i'm level 28 and what's happening to you is happening to me too. I'm so upset because all I've been reading is that the save game file could be corrupted. I can't do anything what so ever, I'm just stuck on a ship as aya with bayek and that greek dude. Plus the objective says Talk to Aya for the blade of the goddess quest. so angry!!!

11-01-2017, 03:32 PM
Sama here :/

11-01-2017, 05:13 PM
Ok, after few attempts to restart the mission, it worked.
For me the problem was that game is confused about which mission you are doing. I had "Ambush at Sea" and "Aya: For The Blade Of The Goddess" both active in my journal, so i wanted to start the latter, and was stuck on the ship with objective "Talk to Aya". After few restarts game loaded cutscene, but it was from "Ambush at Sea" and objective changed to "Destroy the fleet" or something like that. When i finished it, i got prompted that indeed i finished mission i didn't even wanted to start at that moment.

11-03-2017, 01:15 AM
Iím lvl 28 with a day and 10 hours in. I started the ďAmbush at seaĒ mission, but the ďtalk to sayĒ mission marker was up and no enemies spawned. I restarted the mission and it seemed to work but Bayek was on the ship. I beat it and I noticed I didnít have my outfit on. I tried calling my mount and nothing. I check my gear and had all legendary crafting ( I only had 2 legendary and the rest purple before the mission) and lost all my gear, money, crafting materials, everything but the badge and toy quest items. I quit the game and reopened it, nothing. I am trying to redownlod to see if anything happens. I really hope they fix it.

11-03-2017, 11:56 AM
So did any of you have a problem with the original Aya mission where you first meet her in Alexandria? I'm stuck in that mission with no gold marker to go after the 2 Targets Gennadios & Snake...
I Rebooted the console & it doesn't pop up anywhere :/
Probly can't move forward w/ main missions till I have a marker that starts it.

11-15-2017, 06:04 AM
Please dear God tell me a fix exists for this! Iíve tried to play this quest, and it thinks Iím on blade of the goddess. 52 hours in, and itís stuck!!! Iím seeing others with this issue. This is super screwed up! Anybody?! Ubisoft, this is an epic failure!

11-15-2017, 08:36 PM
If you press start and keep restarting the mission it fixes after a couple of tries so you can carry on and finish it

11-16-2017, 07:32 AM
I have a gold account and I am at level 40, had a lot of stuff. I went into this quest and noticed the glitch right away, I just sailed around and nothing made sense so I kept calling it to go back to the last checkpoint. After about my 15th try it finally worked, had fun with a quest that reminded me of Black flag sailing battles. Beat it on my first try Just barely. I looked at my gear nearly right away... everything is gone, items, weapons, resources... even all the papyri I had collected and planned to go back through them and find the treasure... now gone.

Please fix this Ubi.

11-16-2017, 09:59 AM
Same thing here.. lvl 30 or 31.. 41+hrs... it took 47 x reloading the quest objectives to fix this... I'm not going to be happy if all of our gear was nuked in the process.. especially if we don't have what we spent helix for.
Ubisoft... If this many people are having problems, please get a fix, or disable the quest. We don't all want to have to start over because of a broken quest. (xbox one X here)

03-01-2018, 06:00 AM
I'm level 31. Started Aya: Blade of the Goddess and got up to Sink the Fleet (the final one). I can't beat it and I can't get out of it. No matter what I do, it restarts me at the beginning of the battle. I've tried running away and hit a wall (the edge of the map). I tried going to a different mission but they are all grayed out except this one. I've tried reloading the quest objective, restarting the game, etc. If I can't get out of this, it's the end of the game for me. And I was really enjoying it. Help!!!