View Full Version : Bayek Stuck on Ground After Horse is Killed

10-29-2017, 11:22 PM
I have a rather interesting bug to report.

Twice, when riding a horse during combat, the horse has been killed, and I have been thrown from it, and the player character does not stand back up. I can still turn and look around, but I cannot move in any direction, nor can I engage in combat. Reloading the game solves the problem, but only because it resets to the last checkpoint.

Both instances have been in Kanopos, the first while fighting a hippo and a crocodile on the way to Als Hideout, the second is near the docks by the Menelaite Trireme. I have included an image (taken using the in-game photo system) of the second instance of the bug.


It's at least resulted in a fairly funny screenshot, but if anyone has figured out how to stand back up, it would be much appreciated.

10-30-2017, 02:26 PM
Thank you for your feedback, I am sorry you have experienced this issue.

I will pass this onto the Assassin's Creed Origins team for further investigation.

07-11-2018, 01:00 AM
I have the same issue in multiple instances. Right now its at the boss snake. I get knocked down and have to reset the game to continue. I am level 26 if that helps. Same exact pose as above. It gets frustrating.

07-13-2018, 02:44 PM
It happens all the time. I just press X on my controller to get back up.

07-15-2018, 07:22 PM
x doesnt work for me tried it

07-16-2018, 02:25 PM
x doesnt work for me tried it

Are you using alternate control configuration?