View Full Version : stuck in loading screen

10-28-2017, 05:08 PM
Any workaround on this yet or a fix?

10-28-2017, 05:13 PM
Stuck at loading screen and mouse not working inside game only in menus still not on the list.

10-28-2017, 05:40 PM
I'm currently experiencing a bug in the main mission the final weighing. It's where you have to assassinate fluois or whatever his name is. The objective never comes up and when I get near the temple the door always shuts and I can't progress. If anyone knows a work around let me. I died and quit the game and none of those worked. I deleted my game and reinstalling it. Hopefully this will fix it. I will update the post if it works. Just thought you should be aware

10-28-2017, 08:21 PM
I'm experiencing a several freeze scene during the game... the screen freeze and after second starts to running again. I'm playing on Xbox One S.

10-28-2017, 08:34 PM
It is currently possible to acquire multiple copies of the same outfit, however you can not remove or sell these copies. You are permanently stuck with [2] next to the outfit if you have 2. I know this issue isn't as important as many others but I figured i'd report it. Might not be too difficult too fix so you never know.

10-28-2017, 10:25 PM
Hello unhappy friends,

just like you I had the audio issue of no or closely no audio in every cutscene.
Justed fixed the problem on my rig. Tried out all the stuff one can find in this forums but
one thing helped me.

1) Disable ALL other audio devices apart from the one you use (Logitech G35 headset for me)
2) Launch the game
3) Once launched and you are in-game disconnect your device (took out the USB in my case)
4) wait a few seconds
5) replug your device
6) done

I dont know why and I dont know how but now everything is fine for me..
Gonna restart the game and wish you guys good luck.

Kind regard

PS: Pretty sad Ubisoft... but I hope you guys work an this :)

10-28-2017, 11:21 PM
In main quest line only bayak is speaking. Everyone else is mute...I am using Astro A50 headset. All the side quest dialogue is fine. Main quest line isn't

10-29-2017, 01:11 AM
Also a known issue is extremely Poor performance and No SLI support.

Can only get 20-40fps on high, very high, ultra high on 2560x1440 and 1080p

i5 8600k
Asus strix 970 sli (sli is off because its not supported)
16gb ram
windows is all up to date and latest nvidia driver.