View Full Version : I use the HyperX Cloud Revolver Headset and I have a lot of sound/audio bugs

10-28-2017, 05:34 PM
I use the HyperX Cloud Revolver Headset and i'm missing a lot of important game sound so no the issue is not just with Logitech Headsets. No footstep sound, No bush sound when rustling through them, no underwater swimming sound no above surface swimming sound, no climbing sound no landing from jumping sound, no in-game side quest conversation audio, no cut scene audio which is so bad especially for a story driven game. This is game braking people.
11 Xbox bug threads, 14 PS4 bug threads, and 150 bug threads for PC. Clearly, you've neglected the PC version of the game's development... and through that you've neglected the Game Players in the PC Genre of Video Gaming. You've already taken my money and false advertised what the PC version was actually going to be: here give me $60 and i'll give you a bug ridden/infested game that would have been awesome if it worked.. But it doesn't work and you showed it like it did. honestly i don't get how you'd make a game and not even know that you cant hear your own game's audio cut scenes. how does this happen??? so you make a game and don't test the "finished" product (it isn't finished being developed for PC). So you don't play the game to see if you can even hear the cut scenes and not only that but a variety of game sounds that are crucial to the game's enjoyment??...
Robert California (The Office) Once said this and now I'm saying this to you because i think you guys and girls over there at Ubisoft need to hear it:
End the mistakes Andy (Ubisoft), simply end the mistakes.

10-28-2017, 08:48 PM
I have the same problem, just start the game and in the menu of this, I do not stop listening to a sound that looks like a squeak which is quite unpleasant.
After this, i start to lose audio inside the game... -.- come on!

10-28-2017, 10:35 PM
Hello unhappy friends,

just like you I had the audio issue of no or closely no audio in every cutscene.
Justed fixed the problem on my rig. Tried out all the stuff one can find in this forums but
one thing helped me.

1) Disable ALL other audio devices apart from the one you use (Logitech G35 headset for me)
2) Launch the game
3) Once launched and you are in-game disconnect your device (took out the USB in my case)
4) wait a few seconds
5) replug your device
6) done

I dont know why and I dont know how but now everything is fine for me..
Gonna restart the game and wish you guys good luck.

Kind regard

PS: Pretty sad Ubisoft... but I hope you guys work an this :)