View Full Version : Medunamon kill bug

10-28-2017, 03:01 PM
I've just encountered an incredibly weird issue. I started the "Family reunion" mission - the one where you need to go to Temple of Amun in Siwa and free some guys from a cage. I freed them but didn't take the body from the cage to finish the mission. Instead, I decided to go deeper into the temple to explore.
There was a lot of guards inside, I got into a massive fight and was very close to dying. So here I am, frantically smashing buttons, dodge, hit, dodge, dodge. One of the guards hits me and a cutscene starts. I assumed this is what happens when my character dies. That was not the case.

The cutscene showed Bayek talking to Medunamon. Then I played through a short flashback sequence where Bayek was with his son. They hunted together, then went to a cliff where Bayek tried to convince his son to jump to overcome his covardice. Then, one more cutscene where the masked guys captured Bayek and his son and tried to open the crypt. One more cutscene followed where Bayek smashed Medunamon's face with an iron ball. Bam. I have killed Medunamon. Without even knowing how or why this happened.

I am going to restart the game. Luckily, I was just a couple of hours in.
Did this happen to anyone else or am I the only one?