View Full Version : Cannot open the game

10-28-2017, 12:37 PM
What I have:
CPU: Intel(R) Core(TM) i5-7500 CPU @ 3.40GHz
Video Card: NVIDIA GeForce GTX 960
Memory: 8.0 GB
OS: Microsoft Windows 10 (build 15063), 64-bit

I'm having trouble starting Assassin's Creed Origins on my PC. I bought the game through the Ubisoft UPlay store, so it's not on Steam. I have uninstalled and reinstalled the game and I am still getting the same problem:
When I Click "Play" the main game image/title pops up, as if it's loading the game. A secondary window then opens up after ~2 minutes, but doesn't open on my screen, it is just another page open under the original game image/title. When I click this window to open it, a large white screen appears with the Assassin's Creed Pin-bar logo in the center. This window rids of my mouse and I am unable to do anything on my computer screen. I am still able to open the task manager, so my computer isn't frozen. I am assuming that this secondary window is the game itself, but it's just not playing on my computer for some reason. Anything helps, thanks in advance!

10-28-2017, 12:43 PM
Thanks for the information!

Is the game installed on your OS drive?

10-28-2017, 05:47 PM
Hello Guys,

I have the exact same problem as described by xWYLDExWARRIORx.

My Specs:

Processor: Intel(R) Core(TM) i5-6600K CPU @ 3.50GHz (4 CPUs), ~3.5GHz
Video Card: NVIDIA GeForce GTX 1080
Memory: 16.00 GB
OS: Windows 10 Pro 64-bit (10.0, Build 15063) (15063.rs2_release.170317-1834)

Concerning the question asked by Ubi-Rufus.
I did not install the game on my OS drive, but on a seperate drive i use for all of my games.

Help or advise is much appreciated. Thanks in advance!

10-28-2017, 06:23 PM
i can't open this game

i faced same problem

10-28-2017, 06:27 PM

The exact same problem as xWYLDExWARRIORx and JeyTheX.

My Specs:
Processor: 2.8 GHz quad-core Intel Core i7 Kaby Lake (7700HQ)
Video Card: Radeon
Memory: 16.00 GB
OS: Windows 10 Pro on MacBook Pro 2017 - Bootcamp

Also posted a ticket on Friday, no response.

10-28-2017, 09:17 PM
Im also running a 2017 MacBook Pro on bootcamp and running into the exact same issue.

10-28-2017, 09:30 PM
Anyone get a resolution to this issue? Iím
having the same problem

10-28-2017, 10:15 PM
Exact the same problem with almost the same config

10-28-2017, 10:35 PM
In response to Ubi-Rufus:

No, it is not installed on my OS-Drive. I tried re-installing to that, but no luck. All of my games are on a separate, internal drive and are able to play fine anyways.

10-29-2017, 03:25 AM
I am having the same problem. Always seem to have problems with UBI games.

GTX 1070
16GB ram
Win 10

10-29-2017, 05:00 AM
last time this happened I needed to buy a hard copy of the game.

My Specs:
Processor: 4.00GHz AMD FX-8350
Video Card: GeForce GTX 770 driver 388.00
Memory: 32.00 GB
OS: Windows 7

10-29-2017, 07:17 AM
I am having the same problem
amd x4 955
gtx1060 v388.0

10-29-2017, 09:42 AM
Been fighting with the same issues since release.

Anyway: Here is what worked for me.

My game was originally installed on my secondary harddisk (E-drive). Which made me only see splash screen when starting game. After I moved the game to my main drive (C-drive), the game started up without any issues. Maybe that is the same issue with you?

I know it annoying. Having a SSD as my main, had a little more than 50 GB of free space, so one game wanting 41.5 of those... :-/

10-29-2017, 11:33 AM
I tried the advice as suggested by netmolle and it actually worked.
As to why it worked, is honestly beyond me. It's really strange though because I have Rainbow Six: Siege intalled on my E: drive and it does work fine...
Well nevermind that. If you guys have this problem, try the advice as posted by netmolle.

I wish you a splendid day folks.

12-26-2017, 04:59 PM
Hi guys,

This might sound weird but it works for me.

Do not enable your xbox one controller if you are using one. launch the game first and when it starts then u can enable it. You can let the ****le connected to USB but as long as you turn off the controller it should launch.

But if u are wired xbox 360 controller u can just let it connect.

01-02-2018, 08:37 AM
Same here, the game is installed in default steam location (same with OS). 2016 MBP. Should I go for a refund?

12-25-2018, 09:32 PM
Same here - also on a MacBook, also using an external hard drive. I have more than 10 games installed on that drive - all of them work. But Ubisoft games do not. ACB does not start, neither does Origins. I am fed up with this. This is a valid setup, the game should work!!

12-26-2018, 10:11 PM
@pikewerfer ACO is not officially supported for Mac, nor does it support things like a Windows emulator on MAC. It only supports the 64 bit versions of Windows 7 SP1, 8.1 and 10. The minimum requirements are posted here (https://support.ubi.com/en-us/Faqs/000031268/System-Requirements-of-Assassin-s-Creed-Origins).

12-27-2018, 02:09 PM

I AM running Windows 10 native on a MacBook. The 64 Bit version. I am DEFINITELY meeting the minimm requirements.

Once again: This is Windows 10 64 Bit. No emulator It is running native. I expect these games to run. Any other suggestions? Come on, it can't be that Ubisoft is not supporting one of the most popular hardwares (MacBooks) running NATIVE Windows.

No emulator.

12-27-2018, 08:52 PM
Oh! I misunderstood. I assumed you used an emulator. Did you submit your MSINFO and dxdiag files (https://support.ubi.com/en-US/Faqs/Details/kA030000000emSbCAI?name=how-to-submit-dxdiag-and-msinfo-files) for investigation?

12-31-2018, 07:48 PM
Yes, I did, for both Origins and Brotherhood. Both do not work. I will now wait for Feedback. I can't understand that a giant like Ubisoft is not able to support one of the most common hardwares (MacBook). Can't be that hard.....

BTW - I just saw I received some feedback on Brotherhood: The game does not run on Windows that runs on Mac Hardware. Unbelievable! As an alternative, I am supposed to just run the game on my native MacOS. HOW? It says Windows on my CD, and there is no Ubisoft Launcher for Mac. So how do I install it for Mac, and use my key??

01-03-2019, 11:50 PM
We strongly advise against running Win OS on a Mac. I did take a look at your Origins ticket and your MSINFO file. I noticed your GPU has not been updated since 2017. Please try a clean install of your AMD drivers (https://support.ubi.com/en-GB/Faqs/000036734/Clean-installation-of-AMD-drivers). I also noticed you have a load of Oblivion mods installed. It is possible the mod manager you are using is causing conflicts with AC. I'd recommend disabling them or uninstalling them if you could. I did notice a few programs on startup as well, so I would recommend disabling those. Ultimately, we have this performance FAQ (https://support.ubi.com/en-us/faqs/000031701/Performance-Issues-in-Assassin-s-Creed-Origins-ACO/) also available for assistance.

01-03-2019, 11:57 PM
@pikewerfer Additionally, your GPU does not meet the minimum requirements for ACO. Here are the requirements. (https://support.ubi.com/en-us/Faqs/000031268/System-Requirements-of-Assassin-s-Creed-Origins) Here (https://www.videocardbenchmark.net/compare/Radeon-R9-270-R7-370-vs-Radeon-R9-280X-vs-Radeon-Pro-450/2766vs3466vs3683) is a benchmark showcasing this as well. I apologize for the inconvenience.

02-10-2019, 01:32 PM
I'm experiencing the same issue. Have had this game since launch, and it has NEVER worked. I have 234 games in my Steam library, and every one that I've launched there works. My only "problem" game comes from Uplay. I just want Ubisoft to give me a ps4 code and they can have my PC version (digital) back. I'm never buying Ubisoft games on PC.

The support has been so frustrating. Deleting OBS (which took me forever to configure, and now I get to do that all over again), disabling network adapters, ALL services, ALL startup programs. The issue is not my computer, even though there is possibly a workaround on my PC to get it running. Ubisoft games work well on my PS4. I just want to transfer it there, but of course, that's not an option. You can see in my profile that the game has never even launched.

My case is 08009762

OS - WIN10 64 BIT

02-10-2019, 08:52 PM
when i press to play the game, i get the splashscreen and then nothing hapends. my pc shoud not be the problem;
I have: i7-6700, gtx1070ti, 16gb ram, win10 and i am runing the latest Graphics driver
the game is not stored on the os-drive(there is no Space available there).
what do i do?

02-11-2019, 05:24 PM
Can you please verify your game files, and make sure you are running everything as admin:


02-24-2019, 04:36 PM
I'm on the same boat as the OP and many other. The main problem is that I have very little space left in my OS ssd and the game won't fit in there. Like most of you, all my games are installed in other HDD or SSD and they have zero launch issues. Is there a way to address this? It seems to be a hardcoded path issue that prevents the launcher to localize the game main files. If so, what's the workaround? We're in 2019, ffs!

02-26-2019, 09:11 PM
Hey! Could you submit your MSINFO files (https://support.ubi.com/en-US/Faqs/Details/kA030000000emSbCAI?name=how-to-submit-dxdiag-and-msinfo-files) on a ticket, and reply back with your ticket number? I can look deeper into this issue for you.

03-02-2019, 07:59 PM
I'm on a new build with a 1 TB M.2 drive only installed and still getting the same issue.
All other games work great with no issues. I submitted a ticket and have gone through the preliminary steps (disable background apps, clear temp files, checked Windows system files etc.) I have found no issues and It still does the same thing. Frustrating...
I can't help but think this is a Uplay issue.

04-27-2019, 11:13 PM
my game does not open
Phenom 2 x 4 960t
Vga R9 280x
8gb ram
Win 10

Ubisoft does not have eyes for community that we who are fans of Ubi games need that be solved by that we pay dearly in the games.
And nothing you do to correct the error that comes on the first day of the release of the game known as SSE4.

I am outraged at this company that does nothing for we just want to know of our money.

Another game The Division 2 game with this setting in the Middle.
the staff who did the division 2 this year of parabens had nothing to complain about.:louco: