View Full Version : Need Help in Launching the game from steam

10-28-2017, 04:09 AM
Hi, i have problem in launching this game. when i launch the game from steam it says that it will merge with my Uplay account. Afterwhich, it says that "There is a problem in authenticating the ownership of this product". it sucks and i really need to fix this. Thank u.

10-28-2017, 04:39 AM
Hello and welcome to the Forums,

Could you please try this workaround?
STEAM ACTIVATION ISSUE (https://support.ubi.com/en-US/Faqs/000025741/Steam-Activation-Issue-PC)

Let us know if you're still experiencing issues.


11-10-2017, 04:12 AM
Bought the game on Nov. 6 Play for 2 days, 3 hrs total. Have trouble with Uplay activation on Nov. 8. Tried uninstalling/reinstalling both Uplay and ACO (in Steam) nothing is working. Ready to get a refund. Giving one chance before pulling the plug. Additionally, an old copy of AC Brotherhood (on Steam) has stopped working as well.

11-11-2017, 02:32 AM
Hi there! Can you try verifying the game files through Steam (https://support.steampowered.com/kb_article.php?ref=2037-QEUH-3335)? If this does not help, you can contact the Ubisoft Support Facebook (https://www.facebook.com/UbisoftSupport/), Twitter (https://twitter.com/UbisoftSupport), or make a ticket (http://www.support.ubi.com). Hope this helps :)

11-18-2017, 09:23 PM

i did both;

verifying the game files through Steam and

Still not working. I submitted an issue about problem, not responded yet.

Please help me.

11-19-2017, 03:58 PM
have you tried to launch the game from UPlay as admin?

if not, then follow these steps:

1. Close UPlay and steam and make sure they are closed from the tray icons.
2. Go to [Installation Folder]\Assassin's Creed Origins\ACOrigins.exe , right click and choose properties, click on the compatibility tab and check the box "run this program as admin" at the bottom.
3. Run UPlay as administrator and log in.
4. Run Steam as administrator and log in.
5. Click on Play button for ACO in UPlay.

11-19-2017, 04:59 PM
You need to add the cd key you get in Steam to uplay as well. So basically copy paste it in the uplay launcher as well.

11-22-2017, 01:40 AM
Hi AnSTooRuN. I've checked on your support ticket. I'll get this to the right department, and they'll be in touch with you as soon as possible. Thanks for your patience, in the meantime.
For anyone else having an issue like this, if you have tried both of the steps suggested above, please make a ticket (http://www.support.ubi.com) with screenshots of the error message you are getting. If you have already contacted the support page, and are still waiting for a response, you can contact the Ubisoft Support Facebook (https://www.facebook.com/UbisoftSupport/) or Twitter (https://twitter.com/UbisoftSupport) page with your Support Case number. We will be able to look into the cases for you there. Hope this helps!