View Full Version : Can't call my mount (pc version)

10-28-2017, 01:25 AM
I have the whole time this bug that i'm not able to call my mount. Only reloading fix it , but it alway's come back

10-28-2017, 01:29 AM
Hello Assassin! We're sorry to hear that this has been an issue for you. We have a keyboard map (https://support.ubi.com/en-US/faqs/000031689/PC-Controls-for-Assassin-s-Creed-Origins-ACO/) in case you needed it to reference. However, if you're sure you're using the appropriate controls to call your mount and it is still not working as intended, please look into these steps (https://support.ubi.com/en-US/faqs/000025513/General-PC-Troubleshooting/) to see if this helps alleviate what you're experiencing. If nothing that has been provided here is helping you, please reach out to our technical support team (https://support.ubi.com/Cases/New) for further insight. Thank you!

10-28-2017, 10:34 AM
Problem solved you have whistling for luring enemies, for that you need to press the button once. To call your mount you need to hold the key :p