View Full Version : Mouse Lag

10-27-2017, 04:18 PM
hello guys.

i just installed Assassins Creed Origins and started playing but i couldn't enjoy myself because of this frustrating mouse lag like controller raw input. I searched all around the internet and apparently you can try doing 2 things. For me the second thing did the job.
First you go to C/userprofile\documents\AssassinsCreedOrigins\ and there you have a file called ACO you open and scroll all the way down where you will remove something called ControllerFeedback i guess which will have set a strange value(lots of numbers) and then you save it and make it read-only.
Second thing( which worked for me) is to launch the game and go to task manager and set the priority of the game to Normal.

I hope it will help you guys !

Enjoy the game :*

10-28-2017, 12:56 AM
Hi RyzenLP,

Thank you for posting possible solutions.

If anyone else is also having mouse issues, could you please try the second workaround and let us know if it helps you as well?


10-28-2017, 01:05 AM

I had the same issue and setting the process priority to normal seems to work for me as well.
This seems to have been a common problem in the latest AC games actually.

10-28-2017, 03:16 AM
I tried the above, no go.

Not happy that this is being forced on us. Regardless of reason. I'm not buying a controller just to "compensate" for a forced setting in a game that is supposed to support M&K control input. I also played with mouse sensitivity in Windows and on the mouse itself, I have a Corsair RGB.

It's being overridden by the game.

10-29-2017, 11:31 PM
My mouse is now flowing wonderfully across the screen and I can actually move and aim!

10-30-2017, 02:39 AM
RyzenLP, thanks a lot for your solution. It did fix the problem (I've only tried the second option). It also fixed the problem of mysterious crashes 5 minutes after starting playing. I hope Ubisoft can patch it soon.
Best Regards

10-31-2017, 09:08 PM
I am really glad that i could help other people too !! Enjoy the game guys :cool:

10-31-2017, 10:00 PM
Hi. I have tried doing these methods however neither have helped in my case. I know my PC specs is beyond what is even recommended for this game. All other games I play run fine. When I try to play it though it's not working. For the mouse lag and plus fps. Any ideas?

11-01-2017, 10:53 AM
Got the same problem with the mouse control when I run, ride control is always upward. But I left everything to normal. And also the ControllerFeedpack in the ACO deleted. or is there any other way how you can prevent it. or do you wait until a patch comes.

11-01-2017, 11:50 AM
Get it fixed with the mouse control (is always Upwards scrolled).
z: B: Logitech mouse, have everything installed in the PC mouse software was all deleted or uninstalled. Have downloaded new software from Logitech. So, now the setpoint by Logitech opened and on Universalscroll, please take the AutoScroll not take what anders. Now we again without AutoScroll. So take the Universalscroll player for Logitech.

11-01-2017, 04:24 PM
Second thing( which worked for me) is to launch the game and go to task manager and set the priority of the game to Normal.

This solution fixed the problem for me too, but this has do be done everytime after starting the game.... very annoying.

11-01-2017, 07:22 PM
Yes it is very annoying. Unfortunately this is the only i have found to fix the mouse lag and by the way i searched the internet for programs to mantain my priority of tasks on my desired selection and they do not work....I hope a patch will come soon!

11-03-2017, 04:02 AM
I tried both. For me it was changing the priority from High > Normal. Butter smooth. The problem of mouse shuttering was made worse with this latest patch. Wondering if this is related to core count or something.

Windows 10
i5-4690 @3.5
1060 6GB
16GB Ram
Mouse MX 518

11-03-2017, 04:00 PM
I had this to after the update, did both suggestions and now runs smoothly.
Thnx for the workaround.

11-03-2017, 05:28 PM
I noticed some movement lags after patch 1.03 ( just when you make circles with bayek the game starts gliching like horrible delay in the movement and sound gliching aswell , try this one with setting normal priority seems solve this problem,

11-04-2017, 01:50 AM
I've had this same issue since the latest patch. The second workaround seems to work, but it also seems to lead to some other issues. It seems to freeze briefly in the middle of action, like riding through a city. The freezes are over very quickly, but it's still really annoying.

11-04-2017, 10:23 AM

This solution worked wonders for me, but we shouldn't have to do this in order to enjoy a game that we payed for :(

11-04-2017, 11:02 AM
both ways was helpful, but after few hours playng - problem with mouse and kb is back((((

So, now before playing I should delete ACO file. Every time. It`s a annoying.

Problems appeared after patch 1.03

11-04-2017, 12:40 PM
This is the best thing happening to me in a while. I've been getting more and more frustrated by the input-lag of the mouse making it almost unplayable (was thinking of quit playing until next patch).
The second solution with setting the priority to Normal solved all lag, and I even when from playing on HIGH to ULTRA HIGH without any lag.
(Vsync: OFF, 144Hz, 1080p)

i5-7600K @ 4,5GHz
GTX 1060 6GB

11-04-2017, 12:43 PM
Yep, new patched introduced Mouse being laggy and all over the place.
Thank you very much, I did both

11-04-2017, 01:45 PM
I am very glad that i could help this comunity and i hope they will fix this mouse issues in the next patches !

11-04-2017, 07:24 PM
I don't think I have lag but I play with controller mapped to keyboard and mouse. so while moving forward with analog stick and trying to look around with mouse , I get this quick jerking, and characters feet stop moving and he slides like. works fine if I just move by itself or stop and look around with the mouse , but with both at same time it does this. also if moving forward and holding run/accelerate (shift) together or C(crouch) it flickers as well. like it can only see one input at a time.

11-04-2017, 08:17 PM
it must be something with the mapping software, I use joytokey, because it works normally with the keyboard and mouse. but I have never had this problem with any other game.

11-04-2017, 08:51 PM
ok so I got it figured, the controls section in the menus that contains "input device" was greyed out and could not be changed. until I plugged in an xbox controller. then I was able to change it to keyboard and mouse from auto switch and it worky now.

11-05-2017, 01:50 PM
I don't have a controller and I started experiencing this after the patch update. Everything was fine up until then.
Changing the game priority to normal in the task manager fixes it though, but it's annoying as hell to do this every time the game launches.

11-05-2017, 11:27 PM

ty for tips :D...2nd workarounf fixed my mouse :D

11-06-2017, 09:07 PM
Thanks Mate - good catch!:o

11-11-2017, 01:07 AM
None of these worked for me, the first one i didn't want to tamper with game files. The second one helped for about 1 minute and things started to get glitchy. After that I tried setting the priority to above normal, worked for about 10 minutes and then things got super glitchy again. I really hope there will be some kind of patch for this issue.

11-11-2017, 01:41 PM
well,that not work for me too, first, i dont know the (where you will remove something called ControllerFeedback i guess which will have set a strange value(lots of numbers) and then you save it and make it read-only.)what do you mean like this, i was confused,
Next, i set the priority of the game to Normal that not work for me,so what can i do now?can anyone help me plz?

11-13-2017, 12:04 AM
For me the mouse lag started when I had Origin running in the background. As soon as I shut down Origin everything worked perfectly.

11-14-2017, 11:59 PM
ettpunktnoll, many many thanks!

EA Origin running in the background completely kills the experience of keyboard+mouse in the game. After quiting the EA Origin, everything went silky smooth.

Awesome catch mate!

03-30-2018, 06:31 AM
setting the priority to normal did not change my situation ; however, setting it to high did help a little bit let me know if this worked

12-29-2018, 12:15 AM
I have the same problem. Moue start to stutter/lag when near (or under) 65 fps. My game is set to normal by default, setting it to high does not change everything.
Game runs great except mouse, 60-130 fps at 1440p with full settings. It runs nice most of the time, but as soon as I get near the wheat field or pull out the torch (situations when fps dips to around 60+), mouse start to be very unresponsive and jerky :confused:
I experimented with different polling rates and DPI settings but did not manage to achieve fluent 60fps mouse movement, even when I set monitor from 144 to 60Hz

12-29-2018, 09:02 PM
@rulerkelso Have you tried these PC steps (https://support.ubi.com/en-us/faqs/000025947) already? Can you clarify what mouse you are using?

12-30-2018, 01:02 PM
Hi, thanks for your answer :)
Yep, already tried to do that. Im using "Lenovo Y Gaming Precision" and already tried uninstalling mouse software, even plugged in my old mouse, so there is not a problem with my mouse.
But instead I realised that game itself is not the problem, because I have jerky mouse movement in every game when I limit FPS to 60. This just seems to be the first game where I have FPS drops to 60 so I just did not realised this problem till now. I need around 70 or more to have a smooth movement, the more the smoothier.
What the problem could be? Could it be the monitor? Or software problem? Game is smooth otherwise, it is just when I start looking around with the mouse the stutters occurs.
I would attach MSinfo and Dxdiag but I dont see an option to add an attachments.:o

01-04-2019, 12:00 AM
You can submit them on a ticket (https://support.ubi.com/en-US/Faqs/Details/kA030000000emSbCAI?name=how-to-submit-dxdiag-and-msinfo-files), and update this thread with your ticket number.

01-05-2019, 12:37 AM
Thx for the answer.
I solved this problem by installing an year old driver (damn you Nvidia :D) - 390.77 specificially.
Mouse still lags a little, but only when riding the horse/camel.
Also I have much better performance in-game, barely drops under 80fps at ultra settings and 2k resolution.
Maybe ancient Egypt just needed an ancient driver :rolleyes:

01-05-2019, 02:27 AM
Glad to hear you were able to fix it rulerkelso! I hope you enjoy :D

04-09-2019, 06:08 AM
Also having problems tried both solutions (actually origins is set to normal by default) https://support.ubi.com/en-US/Cases/08565034

don't understand someone talking about origins running in background...

04-10-2019, 09:49 PM
Hello trickyness1. The NFO file you provided on your ticket appears to be corrupted. Can you please upload a new copy but compressed (https://support.ubi.com/en-GB/Faqs/000025876/Submitting-files-to-Ubisoft-Support/)?