View Full Version : Mouse not working on PC

10-27-2017, 04:05 PM
Launched the game for the first time. Mouse is not working in menus after startup. The cursor just sits there flashing...similar to issue seen in Unity. Black Flag and prior have no issues on PC. Windows 10 64bit, 24 Gig of ram, I7 cpu 3.6 Ghz, 4 terabytes of disk space. Disappointing...many USB peripherals...seems to have sane Unity detection issues.

10-27-2017, 04:33 PM
I have the exact same issue. Game is unplayable.

10-27-2017, 04:39 PM
mouse will not work just flashes

10-27-2017, 06:12 PM
OK...I had to manually turn on the Keyboard and Mouse in the ACO.ini file in C:\Users\Dean\Documents\Assassin's Creed Origins. Look for this setting:


They were defaulted to 0 for KeyboardMouseEnabled. And 1 for auto switch.

This got the keyboard and mouse working. Shouldn't have to do this manually, the software should detect and set it.

10-27-2017, 11:00 PM
That solved it for me! Thanks machtoo!
Agree, this should not have to be done manually.

10-29-2017, 06:05 PM
Thanks Machtoo...that solved my issue as well. Thanks!

10-31-2017, 11:54 AM
I don't have this in my ACO.ini file:


The file has 3 sections; [Language], [Graphics] and [Startup]

I tried adding the switches given by @machtoo to the [Graphics] section, but it had no effect :(

12-27-2017, 08:36 PM
Same issue here. Unable to play. Have ticket in. Will post if they provide a solution that works. Tried the ACO.ini switch and it didn't work. Likely a usb controller issue as I have a game pad and HOTAS Warthog game contollers on my system. Not willing to take these out as I regularly use them. Don't have this problem with AC Unity.

12-28-2017, 02:55 AM
Hi there!
I highly recommend machtoo's work around:
ACO.ini file in C:\Users\[your name]\Documents\Assassin's Creed Origins. Look for this setting:
If this does not help, please try verifying your game files (Depending if you purchased the game through Steam (https://support.steampowered.com/kb_article.php?ref=2037-QEUH-3335) or Uplay (https://support.ubi.com/en-US/faqs/000019000/Install-Uninstall-Verify-A-Game-in-Uplay/)). Please also make sure your peripheral's drivers are up to date (https://support.ubi.com/en-US/Faqs/000001910/How-Do-I-Update-Drivers-PC).
If none of that works, please make a ticket (http://www.support.ubi.com) with msinfo and dxdiag files attached (https://support.ubi.com/en-US/Faqs/Details/kA030000000emSbCAI?name=how-to-submit-dxdiag-and-msinfo-files). Thanks for your workaround and reports!

NesralNeets, I checked on your ticket. We recommend the steps the agent has provided, as well as the ones above. Please update your ticket accordingly.

12-28-2017, 06:26 PM
Upon further investigation I have found out how to fix this. I currently have a Thrustmaster HOTAS Warthog attached to my system. If I run Target GUI that combines, Joystick, throttle and rudder pedals then I am able to access full mouse and keyboard functions ACO. Of course disconnecting these peripherals also gives me access to mouse and keyboard in game. Everything is working as it should in game.