PDA

View Full Version : [Oculus_Rift] Authentication error when linking Uplay and Oculus account



Schoenster
09-01-2017, 07:21 AM
Yesterday I bought Star Trek Bridge Crew from the Oculus Store. Whenever I start the game it wants me to put down the Headset and log in to my Uplay account. After doing so it shows a message that it now ill be linking my Oculus and my Uplay account. After that I receive an error message.

"There was a problem authenticating ownership of this product. Please contact customer support if you need help solving this problem."

I googled the issue but did not find a solution. I attempted restarting, completely closing the Uplay launcher and letting the game launch it, starting Uplay before Bridge Crew, completely uninstalling and reinstalling both Uplay and Bridge Crew, but to no avail. The error still occurs every time I start the game at the point where you have to recalibrate your camera by pressing the left thumb stick.

mic3wales
09-01-2017, 09:48 AM
Have the same issue. Tried logging out of Uplay and restarting and linking accounts but still getting the same message. Also the game isn't showing up on my Uplay screen making me suspect the accounts haven't linked properly. Submitted ticket to Uplay but still no answer.
Let me know if you have any luck.

Schoenster
09-01-2017, 03:15 PM
I got it working. Leave the Oculus Public Test channel. Then it registers fine.

DrewNexus2017
09-02-2017, 12:18 AM
That hardly seems likes a solution to the problem. Do you just lose access to the Beta if you want to play this game?

DrewNexus2017
09-02-2017, 12:26 AM
Also, I just tried deactivating the Beta in Oculus home and then restarting. I am getting the same issue. When Uplay asks me to link account it states it has trouble authenticating the game. This is so stupid that you have to use some back door program to play this game. I just want to play!! Why is this not working?!

tcz8
09-02-2017, 02:41 AM
I'm having the exact same problem. Had a chat with 2 support agents so far, none of them were able to help. Last one I spoke to said they had been having this problem all day and that she would contact me by email once they have a fix.

Still waiting for the email, but its only been 24 hours.

FYI I do run the beta version of Oculus.

tcz8
09-02-2017, 03:12 AM
Here is how I fixed it:

1- In the oculus home software go to settings (gear icon, top left)
2- Under the Beta section disable "Public Test Channel"

After a few minutes, Oculus will download an update and install it, it will then restart and ask you to update your drivers.

3- Update the oculus drivers from the dialog shown near the top of the oculus software

4- Make sure uplay is not running (not sure if required but i did it)

5- Launch Bridge crew from Oculus Home and this time the linking process should work

Note: This allowed me to link the oculus and uplay account but I still got a communication error after that. If you do, close the game and make sure uplay is running BEFORE launching the game in the oculus software.


Now that the linking is done, I will try reactivating the public test version of oculus home and let you guys know if it works. Cause... Unity.

tcz8
09-02-2017, 03:23 AM
Ok. so it KINDA works.

After running through the procedure above, I was able to reinstall the public test version of Oculus Home and launch the game.

Somehow once you reinstall the public test version it will ask you to link the account EVERYTIME you run the game but this time it succeeds and lets you run the game.

But I did have to start Uplay BEFORE starting the game and one time even then it failed with a communication error, I restarted the game and it worked.

So yeah... a shaky process but at least I can get it to work now.

gommster
09-02-2017, 11:59 PM
I had the same problem, your fix worked very well, thanks

Gwprgwe
09-03-2017, 08:54 AM
Thanks. I will try this workaround when I get home later. I just want to chime in that I have this problem too, and I consider this totally unacceptable by all parties involved. Oculus for not allowing refunds. I always defended Uplay on social media--- "it's just another game launcher...", now I know what the fuss is about.

Schoenster
09-04-2017, 09:26 AM
We decided to run a Beta version and ran into a bug. That's hardly something one can complain about. Instead file a ticket to Oculus so they can fix it in the next stable release.

spiritof1966
11-22-2017, 08:02 PM
We decided to run a Beta version and ran into a bug. That's hardly something one can complain about. Instead file a ticket to Oculus so they can fix it in the next stable release.
I decided not to run a Beta version and ran into a bug. Thats easily something one can complain about. Filing a ticket with oculus isnt going to put the game in my uplay library is it . Personally, I find smart *** armchair experts more offensive than not being able to play a game Ive paid good money for. Unless you represent Ubisoft customer support, you would be better off shutting your yap