View Full Version : Can't start world 2 boss battle

08-31-2017, 05:36 PM
Really enjoying the game but I'm unable to trigger the boss battle in World 2.

My team run through the battle start point, but no cut-scene/battle is triggered? I've tried reloading my save, Switch, etc, but the problem still persists.

Has anyone else had this issue and managed to fix it? Really hoping I don't need to start over...

08-31-2017, 09:22 PM
Solved! By going back to the previous block puzzle and re-doing it, this seems to have fixed the issue.

08-31-2017, 09:24 PM
Hi! Thank you for letting us know about this issue. It would be really helpful if you could contact support directly, so we can better pinpoint the issue. You can contact support here: https://support.ubi.com/en-US/Cases/new

You are welcome to update us here on how the case is going. I will keep an eye out for this thread. Thanks!

09-04-2017, 07:03 PM
I was having the same problem -- that I couldn't trigger the boss for world 2-9. I tried resetting the block puzzle by moving the ice block of the red square to move the gate up and down. After doing this I still couldn't get the battle to trigger.

How much of the puzzle did you reset/redo? Thanks!

09-06-2017, 10:19 AM
also having this problem :( really frustrating... tried resetting the puzzle and nothing happened

09-06-2017, 10:18 PM
I got the exact same issue. Haven't had the time to reset the puzzle yet, but still annoying. Tried everything.

09-07-2017, 07:47 AM
Redoing the puzzle didn't do anything for me... :confused:

09-10-2017, 06:31 AM
Experiencing the same issue here. Resetting the block puzzle didn't do anything to fix it. Here's a vid of the bug in action: https://www.youtube.com/watch?v=ZBeXjpBDkks&feature=youtu.be

09-10-2017, 09:30 PM
This game breaking bug will actually be the end of me playing this game... sad.

09-12-2017, 06:09 PM
I got it working again after I redid the FIRST puzzle. In other words; after I redid the puzzle before the pipe down to the "combo" puzzle with green and blue stones.

09-12-2017, 09:24 PM
Seconding this. To be clear, I moved the block off of the grey, Rabbid-symbol button and then replaced it, re-triggering the brief cutscene where the barricade slides down. I also did this with the block puzzle farther on - just before the ramp to the boss - with the red button. I had Luigi and Rabbid Luigi in my party, if it matters.