View Full Version : Serious issue

08-19-2017, 11:25 PM
I was playing For Honor properly until yesterday. Today,suddenly,I can't launch the game anymore. I can't get past the splash screen,Uplay comes up as if I closed the game,but I didn't. I checker the game files,restarted my computer and installed latest Nvidia Experience drivers,but nothing worked. PLEASE help me!

08-19-2017, 11:35 PM
Did you do a system update or maybe any driver updates in that time? That's the only thing that I can think of that can cause such a sudden change.

Please reach out to support (https://support.ubi.com/en-us/Games/4315) so we can help you troubleshoot further there.

08-19-2017, 11:37 PM
I just installed my latest driver updates thinking that could be the issue,but nothing worked. Latest system update was a few days ago,so it can't be...

08-20-2017, 01:01 AM
Are you running any other programs today that you weren't yesterday? Resource heavy programs, and even things like Chrome can take up a surprisingly huge amount of resources if you have multiple tabs up and could be causing the freeze.

And if you haven't yet - talk to us at support (https://support.ubi.com/en-us/Games/4315)! We have much better tools to help you out there.

08-20-2017, 01:31 PM
No no,same programs. I tried running the game today and it still doesn't work,I don't understand what's wrong...