View Full Version : PC I can't connect UPlay in Far Cry3 Deluxe Edition

07-12-2017, 05:27 PM
So i have bought on sale in Ubisoft shop last year December Far Cry 3 Deluxe Edtion, when I start a game, UPlay is trying to connect to game but every attempt ends with notification "The Far Cry@ 3 service is not available. Please try again later." all the time with no change, I can't play multiplayer, co-op, achieve UPlay points for four task(but I can get achievement) and receive my DLC from Deluxe Edition and UPlay rewards, can someone help me with this?

07-12-2017, 06:43 PM
Delete all ubisoftware and reinstall.

07-12-2017, 06:57 PM
Ubisoftware means what? UPlay application? I

07-12-2017, 07:43 PM
I unistalled and reinstalled uplay and still the same thing :(

07-12-2017, 08:49 PM
I did not find the exact solution :(

07-19-2017, 07:30 PM
The solution is probaly there, but i still don't know what and how to change my router options to see far cry 3 online ;(

11-15-2017, 02:06 PM
To cure this issue you need to contact Ubisoft for your relevant area.

The cause of this issue which was explained to me by a Ubisoft representative is that when you purchase Farcry3 (Any version) the game is automatically allocated to your account. This is done with NO authentication keys. When you load the game it looks for the keys but as there aren't any keys it locks out the multiplayer, Ubistore and other online features.

To solve the problem you contact the customer service team and explain this. They will then remove the game from your account and issue you with an authentication key. You then input this key into Uplay after restarting the app after the game has been removed from your account. There is no need to uninstall the game. Once all this has been done. All should work.

01-24-2018, 06:09 PM
Hi there!
Ticket number 05742402
Looks like i have same problem. But when i tried to explain it to the support they only send me to the network access article. Even when i say that on this PC another Uplay account work fine.

04-15-2018, 08:40 PM
Sorry for late response, but i fixed it by adding UDP and FTP ports to my router, by doing this, now i can connect online to FarCry3 Deluxe Edition but also to 2nd game that didn't worked online for me before-Ghost Recond Wildlands 2nd free weekend, co-op and pvp works.
But there is another problem, i can't recive my DLC content from Deluxe Edition in-game(i recived soundtrack and survival guide in files) but stuff like new missions/animals/weapons etc is locked...
And in Ghost Recon Wildlands, i can't do/complete achievments, i can do Ubisoft Actions and complete them, but not achievments, even when there are Ubisoft Actions wich they are same like some of achievments.