View Full Version : Can't connect to friends squad

06-03-2017, 10:06 PM
Me and my friend have been playing siege like crazy recently and we have had no problems until last night, We tried to invite each other to a game and it would take forever saying its connecting and then would just say failure to join squad. Like I said we haven't had this problem for the past 2 weeks, I looked everywhere and tried everything: Adding Uplay and Siege to my firewall, Opening Squad up to Friends can join, and all the other famous solutions. But for me this isn't working.

Also my NAT Type suddenly went to MODERATE, I got a new network card for my PC and it has been working great. I have had it for 4 days now and my NAT type was OPEN when I began using it. I don't know if my card could be causing the issue.

I also am using a static IP Address if that will help.

My network card is the: TP-LINK T9E PCI-E | I was using the TP-LINK Archer T4U USB adapter before I just swapped out.

Any help would be much appreciated. Thanks in advance!