PDA

View Full Version : [PSVR] Star Trek Bridge Crew Error Code: 21



HMariH
06-03-2017, 09:31 PM
Yesterday I was playing the game for hours, turn off the console save the disk in its box and the next day I put the game between a single game like the other day and at 5 minutes of game I would get out of the game and tell me Error Code: 21 mi Connection is good and I am connected by cable, I think it is a Bug or some kind of Error that comes out without reason, probe to restart the console switch to wifi change DNS, MTU and nothing

I Need help to fix this problem

KobraVenoM
06-04-2017, 11:33 AM
I have a digital copy on PS4 and haven't even been able to play more than 10 minutes before I get error 21. I'm interested in seeing what comes of this since it is a game breaking issue.

dygbio
06-04-2017, 11:17 PM
Having the same issue.

sniper262008
06-05-2017, 03:47 AM
Same problem can't finish first mission before the game just stops and says must be connected to internet.I'm on fiber with no drops in internet with an open nat.

Zoso1492
06-06-2017, 04:05 PM
Same problem with PSVR. No problems the first couple times I played. But now, on the first solo mission on the Aegi, after about 5-10 minutes, I get the loading screen, follwed by the Error Message 21. Internet connection works fine with Netflix, Amazon Prime, Star Wars Battefront, etc.

plant38
06-06-2017, 10:31 PM
same problem here as well...

error code 21 and booted out after no more than 5-10 mins playing all other internet games and streaming work fine even been onto my provider and they have monitoredthe connection they say noting is dropping out...

which providers are you guys with I'm with TalkTalk UK

danniibii
06-25-2017, 08:53 PM
Didn't notice this post and I created my own.
Did you guys manage to fix this issue? I got the game yesterday and haven't been able to complete a mission because of this stupid error 21. Have tried deleting game data and reinstalling but that didn't work.

My brother also got the game yesterday and he hasn't had any problems.
I've also raised a support ticket but until this is resolved it's completely unplayable!

Ubi-Pickles
06-28-2017, 03:18 PM
Hi there. I have taken a look at your case and then agent requested that you try the troubleshooting steps listed here (https://support.ubi.com/en-GB/Faqs/000027239/Connectivity-issues-in-Star-Trek-Bridge-Crew-on-PS4). Once you have done that and you are still experiencing the issue, please update your ticket for further assistance.

danniibii
06-30-2017, 07:37 PM
I have tried the troubleshooting steps and downloaded the latest patch fix that was released yesterday and I still encounter Error Code 21 randomly throughout games. Sometimes 10 minutes, sometimes 20 minutes.

There are NO issues with my connection; I've been using the same setup for 2 years on my PS4 and no other online application or game has any problems with my PS4.

I've updated my ticket with Support but just for awareness I'm replying to this thread in the case that other people have the same issue and, like me, don't know what to do about it.

RPistol
07-07-2017, 05:21 PM
I am having the same issue. Just bought the game and i can play for about 5 to 10 minutes before the error 21 appears. I have also received other error codes as well, such as error 17-6.

I have had now issues with other games having trouble accessing the internet from my home.

I have tried the troubleshooting steps provided but still have the same result.

What makes it so bad is that this game is one of the reasons I wanted to get the PSVR system.

Please get this corrected.

nnndoh
07-11-2017, 07:30 PM
same problem, ps4 is on NAT 2. but can't play for more then 10 min.

Ubi-Pickles
07-12-2017, 02:23 PM
Hi. If you haven't already tried the troubleshooting steps here (https://support.ubi.com/en-GB/Faqs/000027239/Connectivity-issues-in-Star-Trek-Bridge-Crew-on-PS4), please do. And if you still have this issue after trying those steps, submit a ticket at our support site (https://support.ubi.com) for further assistance.

D0ugie007
07-19-2017, 05:30 PM
im, not a tech head - I'm not sure how to port forward and Ubisoft are not interested. they shut my ticket because I was away for 4 days:-9

this is an issue for many people and yet no clear guidelines or help to sort it out!

wenoka2
07-26-2017, 11:59 PM
After trying to do port forwarding, DMZ, Stopping Firewall...nothing worked.

I had an old D-Link WRT54GS....once I change it for a "more recent" D-LINK DIR-615 and it solved my problem

Hope it help

Sylvain

danniibii
08-19-2017, 08:26 AM
So another of my friends recently got STBC and is dying for me to team up with him but my game still doesn't work - error 21.

I've had a ticket open with Ubi for about 2 months and am no closer to resolving the issue. Every response I get from them asks me to check port forwarding, which I've done and amended to what they suggest - no joy. Every SINGLE game I've ever owned on PS has worked fine with my internet connection, why is BC any different?

I'm really beyond irritated now, I just want to throw PSVR and BC in the trash and call it good - complete waste of time and money.
For those with auto-closed tickets at Ubi, you can just reopen them by adding a new comment. I don't have time to be responding in 3.5 seconds between them replying and then auto-deleting the thread so I'm constantly reopening my ticket.

RobDude1616
12-17-2017, 10:37 PM
This game is 100% unplayable. Incredibly disappointing. Internet connection is fine, every other game is fine. This game is not.

Did any of you guys ever get a solution beyond buying a new router? It's been months

joeyalex82
12-24-2017, 02:30 AM
Same here. I canít get all the way through a single station in training, let alone a real mission without error 21. Tried all of the steps, every other online game works fine but this one dies after 10 minutes. On top of that, it doesnít save progress so Iím stuck playing the same 10 minutes of the prologue mission over and over again. Iím not even sure why it needs internet for training and single player mode, seems like a bad idea if the connection is this touchy. I have a ticket open, hopefully they can either fix it or give me my money back. This is extremely disappointing.

Jtgarrett1983m
12-27-2017, 01:51 PM
Same problem.
Made my PS4-System 1 to exposed host. PS4-System 2 can't be this too... but the exposed hosted PS4 has this error too.

Since a week i have a Ticket opened. Now i am on holding pattern since 25 minutes... is there anyone at work?

Play with my buddys and get an DC... then i rejoin and 5 minutes later DC... rejoin and 2 minutes later DC... thats not funny.

Bridge Crew is the only game with this problems...

Jtgarrett1983m
12-28-2017, 11:07 PM
Hi.
I have a solution: Deactivate IPv6 on your Router. Ubi Don't Support it yet.

The German Support told me this and it works 😉

UbiChrisMANG
12-30-2017, 09:23 PM
Hi.
I have a solution: Deactivate IPv6 on your Router. Ubi Don't Support it yet.

The German Support told me this and it works ��

Excellent! Thank you for sharing this with the community!

Greggr12
03-20-2018, 04:06 PM
Hi all,

I'm having Error Code 21 issues about 5 minutes in from starting a solo adventure mission, bought the game 5ish days ago and only starting to have this problem now game worked fine after I purchased it 5ish days ago.

Captain_Summers
05-16-2018, 01:03 AM
From a lot of testing and trail and error I *believe* that this is a network latency hyper-sensitivity bug.

Basically to try and keep all the crew in sync the networking code *probably* does periodic checks to make sure ping / latency is within tolerances.

My suspicion is that that the code that detects this and says it's too high is doing an instant kick rather than waiting a few seconds or averaging it out so that instead of ignoring a momentary peak (local people logging on, neighbour streaming a game, someone else in the house starting Netflix) that would in about 3-5 seconds work itself out, instead the networking code picks this sudden peak up and boom, Error 21.

We've been complaining and bugging this since release. They've NEVER addressed this (publicly at least) the 3 times I've done extensive network diagnostics with Uplay Support) it's either been ignored / dropped by support, or the usual 'we'll pass this to the dev team' and I never hear anything again.

It's hyper sensitive networking synchronisation code. I'd bet money on it.

And they won't fix it.

filmgeek47
05-17-2018, 04:22 PM
I have the same take as summers. Haven’t done exhaustive testing, but it’s the only thing that makes much sense. I’ve only ever run into this a couple of times thankfully, but I’ve been graced with pretty good internet. However the two times I did get the error, absolutely nothing changed about my network setup, leading me to believe it was a temporary latency increase or bandwidth drop and the game freaked out. I have a buddy who’s run into this much more often, and his internet is a big slower and laggier than mine (but still servicible for the vast majority of of gaming). I wish they’d take some time for further networking optimization’s, but it’s probably unlikely unless a lot of people make some noise with their support teams.