View Full Version : Game not recognized by Logitech Gaming Software

05-31-2017, 02:52 PM
When starting Rainbow Six Siege (PC) game the Logitech Gaming Software doesn't recognize this. I had to manually add this game on Logitech Gaming Software but even on starting the game the profile doesn't automatically switch to this game profile.

I have Logitech G502 mouse and it would be nice to have automatic profile layout this game.

06-03-2017, 12:21 AM
The first thing I suggest is to make sure your Logitech Gaming Software is updated to the most recent version. Second, is to verify files of your copy of Siege either through Uplay (https://support.ubi.com/en-Us/Faqs/000019000/Install-Uninstall-Verify-A-Game-in-Uplay) or Steam (https://support.steampowered.com/kb_article.php?ref=2037-QEUH-3335) (whichever you are using). Finally, if that doesn't work, you can reach out to Logitech and make sure your LGS is working properly, or create a ticket at support.ubi.com and speak to an agent by clicking on, "contact customer support." Good luck! :)

09-21-2017, 05:41 AM
Do you u have any solution?

06-24-2018, 03:59 AM
did u fixed it?

06-24-2018, 04:00 AM
did u fixed it????