View Full Version : AC Syndicate, impossible to complete "The Final Showdown"

05-07-2017, 12:31 PM

I have encountered a really annoying bug in the Last Maharaja. At the last part of the mission, when you have to take out the 3 guards and then shoot
the guys hand, the latter part is simply not possible. On the first try my shots will all go right through his hand, doing nothing whatsoever and the timer runs
out. When I start from the checkpoint again then my first shot will hit his hand and the pistol drops, but the quest is not completed and the timer runs down
and the video of the guy shooting the Maharaja will plac without him having a gun in his hand, mission failed. I can also kill all 3 guards from the starting
roof with throwing knives and quickly shoot 12 times and effectively kill the guy with the gun (no lifepoints left). Then the video will play with only
the Maharaja in it, getting shot by a ghost...

I have tried lots of different things, shooting the hand from alternating positions, restarting the mission, restarting the game, combination of the two, played the story further and tried the mission on different sequences, it all does not help. It is simply impossible for me to complete this mission. Is there anything one can do?

05-12-2017, 11:49 AM
you need to run and kill him, ranged weapons will not work, look here at 10:00 mins:


05-13-2017, 03:07 PM
You did not read my entire post I think, because this video does not apply to my situation at all. When i shoot his hand the timer DOES NOT disappear, the objective DOES NOT update to "Assassinate", it stays at "Shoot the hand". Timer runs down -> Mission failed.

09-10-2017, 04:50 AM
I have encountered the same bug.
What ever I try the countdown doesn't stop.
I have retried the mission for dozens, really hope somebody can help me slove this situation!

09-10-2017, 10:42 PM
I cannot remember this... it has come up a few times before but... I think you MUST be on the ground before you shoot his hand or it does not work. (I might be wrong but as far as I can remember that was a fix

06-11-2018, 03:53 AM
Finally managed to complete this DLC on PS4. Take out the three guards with throwing knives, no need to leave the roof, and when you need to shoot the gun from the blond fella's hand, use throwing knives again. Then you trigger the assassination command and you can shoot him or whatever you want. Never left the roof.

No idea why, but this worked. Maybe using the pistol confuses the programming and it still thinks the pistol shot warns blondie and it triggers the death of the Maharaja.

And yeah, a lot of bugs in this particular DLC.