View Full Version : PC First blood action not unlocking, only got achievement for it

03-16-2017, 08:50 PM
Hello, previously I had a steam + uplay version of FarCry3 and when I finished the first fragment of the game, it said at the top "action unlocked", I played two more missions and quit the game. I have an achievement "first blood" for it, but in the "Actions" menu in Uplay. the "First blood action" for finishing the first fragment of the game is still not unlocked. I thought that it may be just one-off issue so I started the game again on the new save, finished this part again, but this time there was no "action unlocked" window at the top. I kept playing the game on my first save, I've got achievements for some activities but still no action unlocked.

So yesterday I've got an uplay only version of Far Cry 3 from CD-Action, activated the key and installed this version. My saves were still in game so I played the game for a bit on my old save thinking that maybe the servers will respond this time, again this time I got some achievements but the action is still not unlocked. So I tried to play the game from the beginning again hoping that it may work, but nope.

I never had any problems with other games in the past, always got both actions and achievements from all Assassin's Creed games. Maybe the problem occured because I firstly played the Steam version of FC3, but still the Uplay need to be launched too so there shouldnt be a problem with it. Anyway, is there any way to fix it, as I really want to unlock this action which I should have and get the uplay points for it, and be sure that no problems will occur with further actions which I should get when I do the proper in-game activities.

Screenshots attached as a proof (in the links below) that I've got the achievement but no related action:
https://scontent.fman1-2.fna.fbcdn.net/v/t35.0-12/17273688_1277683382309826_1260309771_o.png?oh=d1e2 3d7ded7f242d63410fdc18e8faf3&oe=58CC7981
https://scontent.fman1-2.fna.fbcdn.net/v/t35.0-12/17357270_1277683408976490_1759160345_o.png?oh=1d15 119a0d89bee6dd8e65835f2b56a3&oe=58CD7733

04-10-2017, 02:15 PM
I have the same problem as you. I have almost all achievements unlocked but still no actions for First Blood or making 50 syringes. Adding the game to firewall as exception works for some people but it didn't solve the problem for me.

04-27-2017, 10:57 PM
Same problem as you guys, but for me all 4 action dosen't unlock.... That's quite sad. Even more so that unlockas are behind the UbiPoints and i can't unlock them for this game now....