View Full Version : Assassins Creed IV: Black Flag Freezes on game startup.

03-12-2017, 08:40 AM
I had an issue with the game a few years ago when I had first bought it. I had played the game, finished the story and was at that time just working to make my person look good, I had gotten the Mayan bulletproof armour, working on maxing out the upgrades on the Jackdaw, normal stuff. Then I had a bluescreen while playing (unrelated to black flag it was just computer troubles). This broke my save that I had put 34 hours into. Naturally I was pretty mad and un-installed the game. About a year later I decided to get back into Black Flag and play it, I had played the game and gotten to the third mission in Nassau and then in a loading screen my game got stuck in an infinite loading screen. I Alt+F4'd it and tried to do relaunching it to fix it. But the same issue was occurring at the same spot. I googled around and people were having the same issue as me, but there was no fix for it that I saw. So again I un-installed the game. Then a month or so I installed it again to play it. I forgot about why I had last un-installed it but then I quickly remembered as the same problem was happening. I started a new game and then the game would just get stuck in an infinite loading screen on the first one. Today I installed it again (lots of un-installing and installing) and tried to make a new game game and it got stuck in the beginning again. If anyone knows how to fix this issue if you've had it before, or you just know how to fix it then it would be amazing if you could tell me. This game was my favourite assassins creed game and it would be a shame if I could never play it again.

Edit: I am on a PC

03-12-2017, 11:32 AM
The first things to try are to set uplay and the ac4bfsp.exe to run as administrator. For some reason (maybe windows updates) some games and programs that worked before seem to stop working now until they are run as administrator.
Also as Black flag cannot save to cloud, I have my uplay settings "enable save to cloud" turned off.
Have you tried starting uplay in offline mode then play to see if it goes past the loading screen before going back online?

03-12-2017, 09:20 PM
Thanks for the reply.
I have tried everything you said to do, run both UPlay and ac4bfsp.exe as administrator, turned off cloud saving, and making uplay start offline. But for some reason none of that has worked and right when I start the game, and it says in white text "Ubisoft Presents" and then it freezes. I hear the audio of the storm in the beginning, but the screen just freezes and I can't see anything happen. I tried sitting through the cut scene listening to the audio with a frozen screen but then after a minute or so I just hear constant cheering of the ship's crew.

03-12-2017, 11:33 PM
Is your game directly from uplay or steam?

If it is on steam...

go to game directory (Steam/steamapps/common/Assassin's Creed IV Black Flag) and remove all these folders: dlc_1,dlc_2,dlc_3,dlc_4,dlc_5,dlc_6,dlc_7,dlc_8,dl c_9,dlc_10 (Just, remove all these dlc_(X number) folders.

This has worked for some people.

Also quite odd but running it in compatibility mode with windows 95 has worked for some.

Now you have turned cloud save off you should verify your game files, just in case :) I hope you get it running soon

03-13-2017, 03:22 AM
I've at this point tried what you said and everything else I can possibly think of. I really do thank you for helping me out even if I did not get the game working. I really wish ubisoft support would be better. Thank's again.

03-13-2017, 12:25 PM
It's very difficult for support in individual cases. Consoles are identical so any problem affects all of them and any solution fixes all of them. PC's are unique because of all the different components, peripherals, software, virus / malware and user problems... so when a game runs on a million pc's but doesn't run on 5000 it is possible that 10 or 20 solutions might fix 99% but the other 1% will be impossible to fix unless they have the pc to test.

A short while ago, while playing a game, it refused to respond to key input at random times.... I changed the keys in the game layout but nothing worked. I contacted support and they were stumped, by accident I came across someone with a similar gaming keyboard to me and found that a profile on my keyboard started a game using the keys and lights. I must have pressed the certain keys that would start the keyboard game. When the keyboard went into the keyboard game mode it only accepted the correct key input for it's own game and ignored the keys I was trying to press.

Without that game support having my entire pc setup and peripherals, they could never have found a solution. I would never of considered my keyboard being the problem :)

That is why whenever there is a problem, support and we fellow gamers on here ask for as much information as possible, such as pc specs, operating system etc... because hopefully it will show a common link. I remember a certain antivirus used to stop 1 game playing and also people who installed a game called assetto corso found AC Syndicate stopped working because of a profile conflict in nvidia. Fraps and other programs can create problems, plus overclocking and faulty hardware... recently someone on here couldn't play a game and found half his ram faulty... so he didn't have enough memory until he replaced it. These are things that cant be diagnosed through support.

What makes this frustrating is that you have already played it once to completion and so you know that it did run on your pc.... but it's tricky trying to figure out what has changed so it will not run now. I've had blue screens plus huge hardware problems but afterwards I've always somehow managed to get my games working again... the only time I couldn't was when I had a laptop. A game stressed it and I think it overheated and after that, it ran all things except that game... I either caused some problems in the laptop or the laptop didn't like that game :)

I'm sorry I couldn't help :(

03-13-2017, 11:01 PM
Yeah I get what you're saying. I hope one day something will happen and I can play it again. I really do thank you for trying to help.

03-14-2017, 07:55 PM
Please post your system specs

03-20-2017, 11:42 PM
I really enjoy that game, it might be that your pc is the problem. lil uzi vert xo tour life mp3 download (http://vevomack.co/lil-uzi-vert-xo-tour-life/)

03-29-2017, 01:21 PM

Just start Uplay in offline mode, and here you go. This was mine proble too. In offline, it runs smoothly, othervise it stucks at the loading screen and you can listen to the "Anymus sound"

06-21-2018, 07:25 PM
ok ive tried looking just about evry where for a solution if anyone can help would really appreciate it. not only does the game usually crash on start up i found a work around for that alt tab out untill the game has run a bit then go back to it. i also have a stuttering problem. i do not see any option in game for phys x and yes i know where to look ive seen a screen shot of where its located and it is not there on mine. i found one slight sollution and thats to control alt tab and use the option to select what cores the game is using from the cpu and check all but one. there is astill a bit of stuttering although a lot better than before. any idea what i can do to make sure phys x is disabled or what else i can do to remove stuttering or should i just give up and re buy on console?