View Full Version : Helicopter bug

03-09-2017, 02:42 AM
While flying a helicopter in the Santa Blanca Outpost I was chasing a car and all of a sudden I was just gaining altitude and I couldn't maneuver my vehicle at all. I tried LT and nothing would happen. I switched seats with B and it slowly start to fall out of the sky, I tried to take control again and it still was unresponsive. Once it crashed to the ground I got out and the blades wouldn't stop and I tried to get back in and fly and it still wasn't working.

03-09-2017, 03:39 PM
That happened to me last night. I thought it was just that the helo had taken too much damage and it froze the controls. I let the helo climb to altitude and bailed out with parachute. Sucks cause I ended up failing the side mission cause I was not able to continue pursuit of the convoy.

03-09-2017, 04:43 PM
it happened even to me in a side mission where i have to steal an heli from santa blanca for the rebel
after i get into the stolen heli, i couldn't land at the rebel base
LT did not respond and even other buttons